Opened 2 years ago

Closed 2 years ago

#9867 closed defect (fixed)

Titanic: Starship Titanic: _lockCount Assertion fail

Reported by: dafioram Owned by: dreammaster
Priority: high Component: Engine: Titanic
Keywords: Cc:
Game: Starship Titanic

Description

ScummVM: 1.10.0git-3567-g58e6033 64bit
Game: Starship Titanic, GOG (1.00.42c), Windows/English
Tester OS: Win7-64

At the beginning of the game.

This crash can be reproduced by:

  1. When the doorbot asks you to answer "Yes", just wait about 46 seconds.
  2. Answer him them save using ctrl+F5 and reload then wait about 46 seconds.

If you do answer him, then you wait, you will run into another bug that does not crash, but the game gets stuck.

Attachments (3)

titanic-win.001 (105.7 KB) - added by dafioram 2 years ago.
Save at question prompt
titanic-win.000 (105.7 KB) - added by dafioram 2 years ago.
save after answering him
lockCount.png (23.5 KB) - added by dafioram 2 years ago.
Assertion Crash

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by dafioram

Attachment: titanic-win.001 added

Save at question prompt

Changed 2 years ago by dafioram

Attachment: titanic-win.000 added

save after answering him

Changed 2 years ago by dafioram

Attachment: lockCount.png added

Assertion Crash

comment:1 Changed 2 years ago by dafioram

Priority: blockerhigh

This bug isn't blocking, I think, so I am changing to high.

comment:2 Changed 2 years ago by dreammaster

Owner: set to dreammaster
Resolution: outdated
Status: newclosed

This is deprecated now, since I've disabled saving/loading during the Doorbot prologue.

comment:3 Changed 2 years ago by dafioram

It happens if you don't enter in yes or no and just wait. It happens if you don't load or save.

comment:4 Changed 2 years ago by dreammaster

Resolution: outdated
Status: closednew

Ah, in that case, reopening this bug again.

comment:5 Changed 2 years ago by dreammaster

Resolution: fixed
Status: newclosed

Okay. I fixed a bug in a delay timer that could allow the request to be repeated prematurely.. the crash was probably from trying to start a new 'will you help' whilst a prior request was still in progress. Since I can't replicate the problem with this fix, I'm closing the ticket.

Note: See TracTickets for help on using tickets.