Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#9849 closed defect (fixed)

SCI:PQ4: Progress blocking, showing barbie the shoe doesn't register

Reported by: dafioram Owned by: m-kiewitz
Priority: blocker Component: Engine: SCI
Keywords: sci32 Cc:
Game: Police Quest 4

Description

Game: PQ4 Windows GOG
OS: Win7-64
ScummVM: 1.10.0git-3459-g9bb9c0d

At the end of Wednesday you are supposed to show Barbie the red shoe and talk to her. If you show her the shoe she will talk about it, but you won't get the 2 point score, and the day will not end until you get those points.

In order to get the points and be able to end the day you must first talk to her about garcia and then show her the shoe.

At this point I have 356 points which I think is the max you can get until that point.

Its a bug because you've shown her the shoe and the game won't let you progress. I.e., if you go to the morgue the secretary does not let you see the corner.

She gives the same dialog when you show her the shoe before and after asking her about officer Garcia.

Attachments (1)

pq4-cd.090 (60.8 KB ) - added by dafioram 2 years ago.
save

Download all attachments as: .zip

Change History (12)

by dafioram, 2 years ago

Attachment: pq4-cd.090 added

save

comment:1 by dafioram, 2 years ago

It looks like this is a bug in the original game. In this youtube video the player gets blocked at the morgue just like me and has to go back to barbie just to get the two points to get past this. https://youtu.be/1BR1u-qT3J4?t=9422

comment:2 by csnover, 2 years ago

Priority: normalblocker

comment:3 by m-kiewitz, 2 years ago

Owner: set to m-kiewitz

comment:4 by dafioram, 2 years ago

Priority: blockerhigh

Just to be clear the day can be ended and the 2 points gotten if the user shows barbie the shoe after talking about Garcia. So you can show her the shoe before then or not.

At this point in the game it is clear to the player that they must show Barbie that shoe. It was found on Yo Money's lawn who is known to have women from Barbie's place and the lady you first talk to at the strip join says that barbie probably know who's shoe it is and that she would be back later.

Therefore, when the user shows Barbie that shoe initially they will have satisfied that requirement, but the game has a further requirement that you must show it after talking about Garcia.

When the player gets to the end of the day and it does not end they will not know what they did not do since they will believe they did everything (if they don't have a guide).

Since there is no different dialogue difference for showing the shoe before or after talking to Barbie about Garcia it seems like a good solution would be to give you those 2 points if you have showed Barbie that shoe and talked about Garcia in either order.

I have a hard time believing that most people won't get stuck because of this.

comment:5 by m-kiewitz, 2 years ago

I already have a script patch ready. Just trying to get to that point in PQ4 floppy (and had to fix quite a few floppy exclusive issues), to verify that it also works for floppy. So the game bug will be gone in no time.

Please don't change priority. It is indeed a blocker. A blocker bug in the original game, but still a blocker, that should be fixed.

And it is weird. They check if some dialog was accessed, and in case it wasn't, they simply do not grant points but continue on. It's quite obviously a bug. They probably planned to make her say something about not having any idea why you would show her a shoe. Sadly there is no extra voice work, otherwise I could have reinstated that.

Anyway, will get script patched soon. Probably this weekend.

comment:6 by m-kiewitz, 2 years ago

Priority: highblocker

comment:7 by m-kiewitz, 2 years ago

Script patch was added, which works at least for English floppy and German floppy and English CD.

Please test it out, please especially test out that there are also no regressions for the young woman before Barbie is available. The same script is also used for that young woman.

I'm now checking if the player has shown Barbie the police badge. The original game checks, if some dialog has been accessed (but Barbie still answers in case it wasn't - as you said. In case she hasn't seen the badge however, Barbie won't answer).

Commit 4d7d769

comment:8 by m-kiewitz, 2 years ago

Resolution: fixed
Status: newpending

comment:9 by dafioram, 2 years ago

Everything looks good.

1.10.0git-4362-g9c4316b

comment:10 by csnover, 2 years ago

Owner: m-kiewitz removed
Status: pendingclosed

comment:11 by m-kiewitz, 2 years ago

Owner: set to m-kiewitz
Note: See TracTickets for help on using tickets.