Opened 2 years ago

Closed 2 years ago

#9845 closed defect (fixed)

SCI: PQ4: kPalVary(SetStart): signature mismatch

Reported by: bgK Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Police Quest 4

Description

Game: Police Quest 4 DOS / French
ScummVM: eedbb7df4e256e752c861b1828cd4b1ac55d59bc

During the first day, after receiving a phone call from Emmo, Carey's informant, going back to the crime scene triggers a shooting. Trying (and succeeding?) to hit the gunman with your hand gun causes the following error:

[VM] kPalVary(SetStart): signature mismatch in method getHit::changeState (room 170, script 170, localCall ffffffff)!
parameter 0: 0000:008d (integer), should be null, integer
parameter 1: 0000:0002 (integer)
parameter 2: 0000:0064 (integer)
parameter 3: 0000:0002 (integer)

To reproduce, load the attached save game and:

  1. Use your car to go to the crime scene
  2. Hide behind your car
  3. Put your kevlar jacket
  4. Hit the gunman using your hand gun

Attachments (4)

pq4-cd-fr.033 (58.2 KB ) - added by bgK 2 years ago.
Save (French version)
Capture d'écran de 2017-06-17 14-36-48.png (60.8 KB ) - added by bgK 2 years ago.
Error in ScummVM's console
Capture d'écran de 2017-06-17 14-37-08.png (75.7 KB ) - added by bgK 2 years ago.
SCI backtrace
pq4-cd.029 (55.4 KB ) - added by dafioram 2 years ago.
My save game

Download all attachments as: .zip

Change History (7)

by bgK, 2 years ago

Attachment: pq4-cd-fr.033 added

Save (French version)

by bgK, 2 years ago

Error in ScummVM's console

by bgK, 2 years ago

SCI backtrace

comment:1 by bgK, 2 years ago

The error may or may not be related to the following warning I got right before:
WARNING: Uninitialized read for parameter 2 from method hideAndSeek::doit (room 170, script 170, localCall 26ef)!

comment:2 by dafioram, 2 years ago

It is also happening in GOG, Windows, English version.
OS: Win7-64
ScummVM: 1.10.0git-3459-g9bb9c0d

This is caused by getting hit not hitting the gunman. It doesn't happen if you are shot before crouching down or if you have the shotgun. You can actually hit the gunman multiple times with the handgun and it will work fine, but first time you get shot it (before getting the shotgun) it will crash.

by dafioram, 2 years ago

Attachment: pq4-cd.029 added

My save game

comment:3 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report! A fix for this issue has been added in commit 5d046791248ff643c834eb403837a31fc2a40143 and will be available in builds 1.10.0git-3501 and higher.

Note: See TracTickets for help on using tickets.