Opened 2 years ago

Closed 2 years ago

#9838 closed defect (fixed)

GUI: 'LastSelectedGame' setting not restored after GUI language change.

Reported by: macca8 Owned by: bgK
Priority: low Component: GUI
Keywords: Cc:
Game:

Description

When returning to the Launcher following a language change, the last selected game is no longer selected, even though the relevant setting still exists in the Config File.

Apart from this issue, the Launcher rebuild appears as expected (language changed), so possibly a problem within the restoration code (since restarting does resolve the issue)?

Don't know if it's relevant, but my game list contains only one item.

To reproduce, simply select a game, then change the GUI Language.

This bug first appeared when the need to restart ScummVM to complete a language change was removed (1.10.0git681-gc32be8e 4 Nov 2016).
Confirmed with the latest Daily Build (1.10.0git3448-g3b8a7a7 (11 Jun 2017)) on Mac OS X 10.6.8.

Change History (1)

comment:1 Changed 2 years ago by bgK

Owner: set to bgK
Resolution: fixed
Status: newclosed

This is fixed in git master as 9bb9c0d58eea71292d05b4e5515c48ba53d1f194. The fix will be available in the next daily build.

Note: See TracTickets for help on using tickets.