Opened 2 years ago

Closed 2 years ago

#9830 closed defect (fixed)

SCI: GK2: No Menu Music

Reported by: DustyShinigami Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 2

Description

I'm not sure what I've done wrong if anything, but I don't get any music play during the Sierra splash screen or on the main menu. I think I've renamed all the files correctly. The only ones that needed renaming were the .AUD and .SFX files. Every other file has been copied off the discs.

ScummVM version - 1.10.0git3379-g8c31328433
Language of game - English
Version of game - Talkie, CD-ROM
Platform and Compiler - DOS

Change History (5)

comment:1 by csnover, 2 years ago

Keywords: sci32 added
Summary: Gabriel Knight 2 - No Menu MusicSCI: GK2: No Menu Music

Thanks for your report! I am not able to reproduce any issue with music playback at the start of the game with either the 1.0 US release or the 1.1 Steam/GOG release. Please answer these questions:

  • Is the music volume set at an appropriate level in the game’s ScummVM settings?
  • Does ScummVM show any warnings in the console? If so, please provide them.
  • What did you rename the files from the CDs? Could you please attach a copy of your game directory structure (dir /s on Windows, ls -lR on *nix)?
  • Does music/ambient SFX work correctly in places other than the main menu?

For reference, the intro audio is audio.34 and is usually found in RESSFX.001 (CD release) or RESOURCE.SFX (Steam/GOG release).

Thanks,

comment:2 by DustyShinigami, 2 years ago

The music level is set to max, which is 256. SFX and speech are locked at 192. No error or warning messages appear in the console. Ambient and SFX all seem to work correctly from what little I've played so far. How would I go about attaching a copy of my game directory? All the RESOURCE.AUD and RESOURCE.SFX have all been renamed to RESAUD.001-006 and RESSFX.001-006 respectively.

I should note as well that the menu music plays if the game is loaded up in windowed mode. If it's in fullscreen, it doesn't.

comment:3 by csnover, 2 years ago

Sorry for the delay.

How would I go about attaching a copy of my game directory?

Run the command indicated for your OS and use a redirector to send it to a text file (e.g. dir /s c:\path\to\gk2\directory > output.txt), then attach that file by clicking “Attach file” at the top of this ticket, just below the yellow description box.

I should note as well that the menu music plays if the game is loaded up in windowed mode. If it's in fullscreen, it doesn't.

Would you please double-check this? I cannot come up with any plausible scenario of how this could happen, and cannot reproduce it.

comment:4 by criezy, 2 years ago

I can reproduce the issue with the GoG version of the game and current code (revision 4cfb93c) on mac.
The issue only happens when starting the game in fullscreen mode with Normal or one of the X2 scalers. I do get music when starting in windowed mode, or in fullscreen mode with either a X3 scaler or OpenGL mode.

This is indeed a very strange issue...

comment:5 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report! A fix for this issue has been added in commit 61f07c13d3e2f0b3967eeb43523855493f7f89d6 and will be available in builds 1.10.0git-3427 and higher.

Note: See TracTickets for help on using tickets.