Opened 2 years ago

Closed 2 years ago

#9823 closed defect (outdated)

SCI: KQ7: Mysterious Device doesn't charge, initially

Reported by: dafioram Owned by: dafioram
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: King's Quest 7

Description

ScummVM: 1.10.0git-3348-g30b5fc8
OS: Win7-64
Game: King's Quest 7 v1.4+NRS patch English

When I first plug in the mysterious device it doesn't charge and even after taking it out and putting it back in repeatedly it won't charge, but after restarting via death it works.

Attachments (1)

kq7-cd-win-1.016 (72.2 KB ) - added by dafioram 2 years ago.
save

Download all attachments as: .zip

Change History (7)

by dafioram, 2 years ago

Attachment: kq7-cd-win-1.016 added

save

comment:1 by csnover, 2 years ago

Resolution: worksforme
Status: newpending

Thanks for your report! I don’t know what differences exist between 1.4 and 1.51, but at least in 1.51 I was not able to reproduce any problem when plugging in the mysterious device; it was charged after being plugged for a short while, as expected. Could you please delete any non-Sierra patches from your game and retry this section?

comment:2 by dafioram, 2 years ago

I have removed the NRS patch and this bug is 100% reproducible in 1.4. Its not a big deal since the mysterious device charges after you die.

comment:3 by dafioram, 2 years ago

Here is a video showing the behavior. I am unable to charge the mysterious device, but once I die I can after pulling it off and putting it back on. This was without the NRS patch on 1.4 and on scummvm: 1.10.0git-3567-g58e6033

Video: http://sendvid.com/p106p6w1

comment:4 by dafioram, 2 years ago

That link wasn't working so here is a new one. https://streamable.com/sfyj7

comment:5 by csnover, 2 years ago

Resolution: worksforme
Status: pendingnew

comment:6 by dafioram, 2 years ago

Owner: set to dafioram
Resolution: outdated
Status: newclosed

This bug is no longer reproducible when playing v1.4 from the start of the last chapter in the current scummvm, 1.10.0git-4882-g1504f41.

If the previous attached saved game is loaded then it still contains the bugged state in the current scummvm version.

Note: See TracTickets for help on using tickets.