Opened 2 years ago

Last modified 12 months ago

#9821 pending defect (invalid)

SCI: GK1: Music is too loud at end of game

Reported by: DustyShinigami Owned by:
Priority: low Component: Engine: SCI
Keywords: sci32 original Cc:
Game: Gabriel Knight 1

Description

The music goes a bit too loud during the final confrontation against Tetelo that it makes it hard to hear what she says. This happens even if the music quality is set lower than the speech/SFX. I've attached a save.

ScummVM version - 1.10.0git3355-g266f68c21b
Language of game - English
Version of game - Talkie, CD-ROM
Platform and Compiler - Win32

Attachments (1)

gk1-cd-win.016 (49.6 KB ) - added by DustyShinigami 2 years ago.

Download all attachments as: .zip

Change History (6)

by DustyShinigami, 2 years ago

Attachment: gk1-cd-win.016 added

comment:1 by csnover, 2 years ago

Keywords: sci32 added
Resolution: invalid
Status: newpending
Summary: Gabriel Knight 1 - Music goes too loudSCI: GK1: Music is too loud at end of game

Thanks for your report!

This game does not reduce music volume during speech playback, so this problem also exists in the original interpreter (verified in DOSBox via a Let’s Play). It isn’t a bug in ScummVM, and it doesn’t seem to be some accident in the game scripts (there is nothing resembling a call to change music volume during speech playback).

I’m also unable to reproduce a problem with manually turning down the music volume; both AdLib and CoreAudio (General MIDI) music volume is reduced correctly here by turning it down in both the ScummVM GMM and the in-game settings window, which helps to make the quiet speech more audible during this scene.

If you can provide more information (like a series of reproduction steps, and more information about your configuration) about the manual music volume not working, that can be investigated, but otherwise I don’t think there is anything that can done here; the game just doesn’t have the best audio mixing or consistent speech volume.

comment:2 by DustyShinigami, 2 years ago

More information about my configuration... Do you mean my ScummVM settings for the game, or my actual PC's hardware? The audio I have under ScummVM is Microsoft GS Wavetable Synth as I like the MIDI music in adventure games with this option.

During the sequence, when I'm able to access the options during scenes like this, clicking on my current music level makes the music go back to the volume set.

If it's part of the original game, and I recall the game under DOSBox having the same issue too I think, then fair enough. But you're right - the audio quality and equipment used isn't the best.

comment:3 by digitall, 12 months ago

Keywords: original added

comment:4 by digitall, 12 months ago

I assume this was set pending on a replication case / steps to reproduce.

Since this is an original bug / issue, will drop priority to low.

comment:5 by digitall, 12 months ago

Priority: normallow
Note: See TracTickets for help on using tickets.