Opened 2 years ago

Closed 2 years ago

#9805 closed defect (fixed)

SCI: GK1: Day 6, Police Station Bug

Reported by: DustyShinigami Owned by:
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 1

Description

Looks like the infamous police station bug has made its way back. After convincing the beignet guy to return to the police station, he moves past the window far too quickly and the cop returns too soon when trying to enter Mosely's office. Even lowering the speed doesn't seem to make a difference. Gabriel will walk slower towards the door, but the cop still comes back in too soon.

I've attached a save on the map ready for the police station to be selected.

Attachments (1)

gk1-cd-win.003 (44.1 KB) - added by DustyShinigami 2 years ago.

Download all attachments as: .zip

Change History (14)

Changed 2 years ago by DustyShinigami

Attachment: gk1-cd-win.003 added

comment:1 Changed 2 years ago by DustyShinigami

Sorry, forgot to add that I'm using:

ScummVM version - 1.10.0git3348-g30b5fc8c36
Language of game - English
Version of game - Talkie, CD-ROM
Platform and Compiler - Win32

comment:2 Changed 2 years ago by DustyShinigami

It looks like I can't continue my testing due to this bug. :-\

comment:3 Changed 2 years ago by csnover

Keywords: sci32 added
Summary: Gabriel Knight 1 - Day 6, Police Station BugSCI: GK1: Day 6, Police Station Bug

Turn the speed up, not down, and you will be able to complete this part of the game successfully. However, I imagine it was intended to be completable regardless of ego’s walk speed, so a script patch is probably in order.

comment:4 Changed 2 years ago by m-kiewitz

Owner: set to m-kiewitz

This is really weird, because I think I patched it using seconds not cycles.
Will take a look into it.

comment:5 Changed 2 years ago by DustyShinigami

Ahhh, up. Okay, thanks. I'll try that out. I read somewhere that if you wait for Frick to 'fall asleep', or rather - when his head is down writing, you can sneak past. His head always appears down whilst he's writing, but I still can't get past him. Leaving the station and returning results in the beignet guy completely disappearing making it impossible to continue.

comment:6 Changed 2 years ago by dafioram

I was able to reproduce this bug by loading the save game on 1.10.0git-3309-g63a87ac win7-64.

I was able to bypass it by turning up the speed (before entering the police station) or by leaving the police station (after initially going there) and coming back at which time the police officer has fallen asleep.

The police officer will start to nod off and then he will eventually fall asleep. He will wake up, but he will nod off again. This cycle gets repeated.

comment:7 Changed 2 years ago by DustyShinigami

Good to know. I left the station after Frick goes out and came back and he does indeed fall asleep. :) If you just stand around and wait for him to return instead of trying to get into Mosely's office he comes back in and eventually starts to nod off. I also left the station after the cops came back in and then returned and he starts to nod off, too.

comment:8 Changed 2 years ago by m-kiewitz

Can you please run ScummVM using parameter "--debugflags=ScriptPatcher" and then check if any patches are applied when restoring the saved game.

comment:9 Changed 2 years ago by m-kiewitz

Hmm, I verified that our script patches are getting applied and they do as they should.
They set a timer to trigger after 23 seconds.

When I walk to the door, the state triggers after around 10 seconds only. Script patch seems to be fine, it seems something else is causing this.

The police officer is also supposed to sleep for around 42 seconds. This is set by another script patch, which fixes original game behavior. Can you please check if the police officer wakes up faster than that? Maybe depending on if you move around or not?

Maybe you only got through while police officer was sleeping because the timer is 42 seconds instead of around 20.

comment:10 Changed 2 years ago by m-kiewitz

nvm, it seems walking through the little thingie will set a cycle timer again.
Weird that this never caused any problems before. Should be trivial to fix.

comment:11 Changed 2 years ago by m-kiewitz

Should be fixed by commit 04b5c3a

comment:12 Changed 2 years ago by m-kiewitz

Resolution: fixed
Status: newpending

comment:13 Changed 2 years ago by csnover

Owner: m-kiewitz deleted
Status: pendingclosed

Verified fixed.

Note: See TracTickets for help on using tickets.