Opened 2 years ago

Closed 6 months ago

#9804 closed defect (duplicate)

No ScummVM version

Reported by: neosmagus Owned by: digitall
Priority: normal Component: Port: Win64
Keywords: Cc:
Game:

Description

ScummVM -v doesn't display version. Neither does ScummVM --version.

Windows 7 64-bit
ScummVM 64-bit, latest download

Attachments (1)

version.png (8.1 KB) - added by neosmagus 2 years ago.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by neosmagus

Attachment: version.png added

comment:1 Changed 2 years ago by dafioram

I get the same behavior via the command line or the powershell, but it did work when I used a mingw command line like git bash.

comment:2 Changed 18 months ago by dafioram

It does work for the kirben win32 builds, but not the buildbot ones (32/64).

comment:3 Changed 18 months ago by Mataniko

The official builds are compiled in a Docker container. It looks like there's a known bug in how MSYS2 in Docker redirects stdout to a pseudo-terminal output. See https://github.com/docker/for-win/issues/262 for details.

comment:4 Changed 18 months ago by wjp

That's for running in docker; not building in docker.

comment:5 Changed 7 months ago by digitall

Component: --Other--Port: Win64

comment:6 Changed 6 months ago by digitall

Owner: set to digitall
Resolution: duplicate
Status: newclosed

#10809 is a duplicate of this, but with more information so closing this as duplicate.

Note: See TracTickets for help on using tickets.