Opened 3 years ago

Closed 4 months ago

#9803 closed defect (fixed)

SCI: SQ6: Quiet music on loading save game

Reported by: neosmagus Owned by: sluicebox
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Space Quest 6

Description

ScummVM: 1.10.0git3335-gcb527ac
Game version: Dos 1.11, Space Quest Collection Series CD
Windows: 10 64 bit

Initially game worked fine, I played until the bar on Polysorbate, saved and quit. When I reloaded the game the next day, the music was inaudible. I could barely hear it, turning the volume all the way up. Speech and sound effects work fine. I attempted adjusting volume in game, in ScummVM and my actual speaker volumes.

Attachments (1)

sq6-cd.001 (39.2 KB ) - added by neosmagus 3 years ago.
Save game

Download all attachments as: .zip

Change History (10)

by neosmagus, 3 years ago

Attachment: sq6-cd.001 added

Save game

comment:1 by neosmagus, 3 years ago

Summary: Quiet music on loading save gameSCI: Quiet music on loading save game in Space Quest 6

comment:2 by csnover, 3 years ago

Keywords: sci32 added
Summary: SCI: Quiet music on loading save game in Space Quest 6SCI: SQ6: Quiet music on loading save game

Thanks for your report! This appears to be the same problem as #9578, where the game ends up with an improper music volume level in the bar. As with that ticket, simply walking to the basement of the bar corrects the volume.

comment:3 by csnover, 3 years ago

Keywords: midi added

comment:4 by csnover, 3 years ago

Owner: set to csnover

comment:5 by digitall, 2 years ago

Owner: csnover removed

comment:6 by ZvikaZ, 7 months ago

This should be fixed with pull request 2074, which was already merged.

Please verify with nightly release that it's indeed solved.

comment:7 by sluicebox, 4 months ago

This is unrelated to PR 2074. That PR changes General Midi code, and no one has mentioned GM here. This is a script bug.

comment:8 by sluicebox, 4 months ago

I've fixed the seemingly related script bug #9578 in which SQ6 music volume in this area ends up too low: fd13a9bf92afef9087837cda8bc3f7ad8f79122b

Even though they seem similar, I don't have an explanation for this one based on the description of what happened. I also can't reproduce it.

The music volume is all the way at zero in this saved game and the reporter says that music was playing normally when they saved. This isn't the master music volume that ScummvM syncs with, but the gSound1:vol property. gSound1 is the global sound object that plays SQ6 music. The script bug does cause gSound1:vol to be too low, but I don't think it can get it to zero, and it doesn't involve saving/restoring.

This saved game will always restore with no music, so the question is how gSound1:vol ever got set to zero in the bar.

comment:9 by sluicebox, 4 months ago

Keywords: midi removed
Owner: set to sluicebox
Resolution: fixed
Status: newclosed

Now I can explain it.

This bug from three years ago was a combination of script bug #9578 and a separate bug I fixed last year where Sound:vol wasn't being updated by the interpreter: 99a7478cd60ad4f0167dc4a8d0ac6498ca012d8b

Note: See TracTickets for help on using tickets.