Opened 2 years ago

Closed 2 years ago

#9791 closed defect (invalid)

SCI: GK1: Intro movie plays no digital music

Reported by: GermanTribun Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 1

Description

In the German version of the game with the newest snapshot, the intro movies defaults to MIDI music, despite the fact it should play the digital music (which it does for the opening credits). Perhaps the file got renamed for the German version and the interpreter is confused? Maybe this also goes for the other parts were digital music is played?

Unrelated, the movies also play in VGA resolution, but that's a good thing, since otherwise they'd be too small, and this shouldn't be changed.

Change History (8)

comment:1 by GermanTribun, 2 years ago

Summary: Intro movie plays no digital musicSCI: GK1 Intro movie plays no digital music

comment:2 by csnover, 2 years ago

Keywords: sci32 added
Owner: set to csnover
Resolution: invalid
Status: newpending
Summary: SCI: GK1 Intro movie plays no digital musicSCI: GK1: Intro movie plays no digital music

Thanks for your report! I am making an assumption that you have selected the DOS version of the game when adding it to ScummVM. What are you describing is the correct and expected behaviour. The DOS version of GK1 uses synthesised music during video playback. (The credits in the DOS version are not video.) If you want digital audio during videos, choose the Windows version instead.

Please let me know if this resolves the problem so I can close this ticket. Thanks!

comment:3 by GermanTribun, 2 years ago

No, that didn't help me at all, since I do have the DOS version only (the German version never came out for Windows). I tested it with DOSBox, the correct behavior is digital music being played in the movies (all the wav-files are accounted for as well). Selecting the Windows version makes the videos not play it all, since it's no Windows version.

Thus my point is valid that the music behavior is plain wrong. Maybe there's a difference between the US and German version in how a number of music pieces are handled? I remember the music in the opening credits being different as well. (In the German version, the much more well known Gabriel Knight-theme is used).

comment:4 by csnover, 2 years ago

Resolution: invalid
Status: pendingnew

OK, thanks for the additional information. What you are describing is definitely different than the US/English release, which operates in the manner I described. I was not aware of the extent to which Sierra’s localisers changed game features.

It also looks like someone was a little overeager when adding platforms to the GK1 detection table entries; if there is no Windows version, ScummVM should not allow that. So that option will be removed shortly.

The missing audio problem you are describing is probably related to the use of SCI16 audio code in GK1 (which I suspect is causing most/all of the other audio problems that have been reported). I don’t have an ETA on this but it is high on my list of priorities.

comment:5 by GermanTribun, 2 years ago

Some additions:

Things do get more curious, here some observations:
-In the US-release, at least one, there is other music instead of the Gabriel Knight theme in the credits. Digital music is played for the music. See in this video: Video
-If you select low-res in the German version, you get MIDI music during the video, but the correct theme during the credits. See here: Video
-Selecting hi-res, you get the correct music for both in digital form.

Some interesting files of the German version:
5.wav is the Gabriel Knight theme that plays in the opening menu and the opening credits
99.way is the nightmare masic
5400.wav is the closing credits music (which plays in the opening credits of the US version above)
Most other wav-files are sound effects, with 201.wav being the cars on the map screen (the map screen does have midi music).

Maybe this helps along?

comment:6 by GermanTribun, 2 years ago

Small addition:

Perhaps it can be programmed if the correct wav-files are detected, they always take priority for the music? That would certainly be good, since the digital music is way superior.

comment:7 by csnover, 2 years ago

Resolution: invalid
Status: newpending

So, unfortunately, I am still under the impression that that this is not a valid issue.

-In the US-release, at least one, there is other music instead of the Gabriel Knight theme in the credits. Digital music is played for the music. See in this video: ​Video

This YouTube video is taken from the Windows version of the game.

-If you select low-res in the German version, you get MIDI music during the video, but the correct theme during the credits. See here: ​Video
-Selecting hi-res, you get the correct music for both in digital form.

I am unable to verify this. This hi-res German playthrough on YouTube plays MIDI during the intro. (You can tell it is MIDI because it is in stereo; SCI2 did not support stereo digital audio.)

Also, there does not appear to be anything in the German version’s game scripts that would cause music to play differently depending upon graphics mode. The music played during the intro video in DOS is unconditionally resource 100. Resource 99 is not used. (It is not unusual for games to contain unused resources.) In fact, the game script in the German version of GK1 for the intro is identical to the script in the US English version except for an irrelevant SetDebug call.

All I can think is that DOSBox is configured to use General MIDI, but ScummVM is configured to use AdLib, so you think DOSBox is playing sampled audio when it is not? All the other evidence I can find points to there not being any sampled audio in use during the intro in any DOS version of the game.

If you are still under the impression that your game is playing digital audio in DOSBox during the intro, could you please do the following:

  • Run INSTALL.EXE in DOSBox and make sure your music device is set to “Sound Blaster / AdLib”, then replay the intro to verify the music does not sound like FM synth now
  • Check for 190.SCR and 190.HEP files in your game directory and attach these files to this ticket if they exist (normally they would be either in the root of the game directory or in a PATCHES directory)
  • Calculate and provide a hash (MD5 or SHA1) of your RESOURCE.MAP, ALT.MAP, RESOURCE.000, RESOURCE.ALT, and SIERRA.EXE files
  • Open the game’s VERSION file and put its content in this ticket

Thanks!

comment:8 by csnover, 2 years ago

Status: pendingclosed

As there has been no response to the request for information for two weeks I am going to close this ticket for now. It can be reopened any time in the future once the requested steps in the previous comment are performed to verify this is actually a defect in ScummVM.

Note: See TracTickets for help on using tickets.