#9789 closed defect (fixed)

SCI: KQ7: No music for quest in Etheria

Reported by: ADeadTrousers Owned by: csnover
Priority: high Component: Engine: SCI
Keywords: sci32 Cc:
Game: King's Quest 7

Description

Normally when entering the area with the hummingbirds in Etheria they will sing you a song which will help you in the quest with the harp. But currently they only fly around Valanice without music.
Savegame is being added. Just go south.

I'm using ScummVM 1.10.0git3279-gdec12f5b6d (May 14 2017 16:22:36)
My operating System is Windows 10 64 bit but I'm using ScummVM in 32 bit.
The game is the CD version.
The language is german.
According to the version file the game version is 1.51

wkr ADT

Attachments (1)

kq7-cd-win-de.001 (63.7 KB) - added by ADeadTrousers 23 months ago.
Just go south to experience no sound from the hummingbirds

Download all attachments as: .zip

Change History (10)

Changed 23 months ago by ADeadTrousers

Attachment: kq7-cd-win-de.001 added

Just go south to experience no sound from the hummingbirds

comment:1 Changed 23 months ago by wjp

Summary: SCI: King's Quset VII - No music for quest in EtheriaSCI: KQ7: No music for quest in Etheria

comment:2 Changed 21 months ago by csnover

This is an interesting bug. In 1.51, the sound that is played during this event only has a track for General MIDI + some unknown type 11. In 2.00b, the same sound has an AdLib and MT-32 version as well. So it seems that this version of KQ7 was intended to only be played with General MIDI, and we may just need to ignore MIDI device settings and force it to General MIDI.

comment:3 Changed 21 months ago by bluegr

IMHO, it's probably not a good idea to override the user's audio setting and mix music from another type of audio device, from inside an engine.

There's a similar issue with the audio tracks in the Amiga version of Laura Bow 1, when using the MT-32 driver. We throw a warning when there's no music data for the for such issues in SCI0 games in MidiParser_SCI::midiFilterChannels()

comment:4 Changed 21 months ago by bluegr

I can't edit my comment above... I meant this: "We throw a warning when there's no music data for SCI0 games in MidiParser_SCI::midiFilterChannels()"

comment:5 Changed 21 months ago by ADeadTrousers

You are right.
I switched from my digital headset to my old anlaog SoundBlaster and now I hear the sound.

comment:6 Changed 21 months ago by ADeadTrousers

Owner: set to ADeadTrousers
Resolution: fixed
Status: newclosed

Ok, now I also got the headset to work.
I just activated "Microsoft GS Wavetable Synth" as default Audio.
I will mark it as closed now.

comment:7 Changed 21 months ago by csnover

Resolution: fixed
Status: closednew

I am reopening this ticket because this is still a problem that needs to be addressed in ScummVM so that other users do not encounter the same problem with this version of KQ7. We can’t allow games to be broken like this with the default settings.

comment:8 Changed 21 months ago by csnover

Priority: normalhigh

comment:9 Changed 21 months ago by csnover

Owner: changed from ADeadTrousers to csnover
Resolution: fixed
Status: newclosed

Thanks for your report!

In KQ7 1.51, there are at least two sounds missing AdLib tracks entirely (13 and 6301), and at least one sound with an AdLib track that has no data in it (6153). 166 of 305 sounds contain different AdLib data versus KQ7 2.00b, amounting to 180KiB of missing AdLib data in 1.x. KQ7 1.51 is also missing data for MT-32 tracks. So, non-GM sound modes in this version of KQ7 are disabled.

A patch for this issue has been committed at 07d6ffd989ce89e52c6381d8c9a2c53ffaa7e05e and will be available in daily builds 1.10.0git-3744 and later.

Note: See TracTickets for help on using tickets.