Opened 2 years ago

Closed 2 years ago

#9786 closed defect (fixed)

SCI: KQ6: Some inventory items have bad palette in the menu bar

Reported by: OmerMor Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

ScummVM version 1.10.0git3272
King's Quest 6 CD version 1.000.00G
Playing with "Enable high resolution graphics" turned on, platform is either DOS or Windows.

Some inventory items (the copper coin, the tinder box) are shown with bad palette artifacts.

Repro:
Start the game.
On the beach, pick up the wooden plank.
"Use" the box underneath.
Pick up the copper coin.
Open your inventory.
"Select" the coin, and and exit.
Hover to the menu bar: the coin appears with bad artifacts.

Attachments (2)

2017-05-13.png (89.2 KB ) - added by OmerMor 2 years ago.
2017-05-13 (1).png (80.8 KB ) - added by OmerMor 2 years ago.

Download all attachments as: .zip

Change History (8)

by OmerMor, 2 years ago

Attachment: 2017-05-13.png added

by OmerMor, 2 years ago

Attachment: 2017-05-13 (1).png added

comment:1 by OmerMor, 2 years ago

The bug reproduces in ScummVM 1.9.0.2.

comment:2 by m-kiewitz, 2 years ago

Hmmm, same problem happens even in ScummVM 1.7
It seems it only happens for hires.

Problem does NOT happen when using original interpreter under Windows 3.11.

It doesn't seem to be caused by hires portraits. I just grabbed the coin in 1.7 without getting any hires portraits and the palette issue still happens.

comment:3 by m-kiewitz, 2 years ago

hires buttons for game menu are inside view 912
hires inventory for game menu is inside view 972/973.

coin is view 972/973, loop 0, cel 8.

It seems those use the first 64 colors.

lowres inventory is inside view 970/971. embedded palette seems to be the same.

comment:4 by m-kiewitz, 2 years ago

more hires buttons like walk are inside view 981.
lowres buttons of that are inside view 980.

comment:5 by m-kiewitz, 2 years ago

Issue already happened even in ScummVM 1.3.1.
It seems as if it always happened and is not a regression.

comment:6 by wjp, 2 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed

Thanks for the report. This should now be fixed by commit 388419c53cce03171ab857ec3c7b6958eca272ca and in the next daily build.

Note: See TracTickets for help on using tickets.