Opened 2 years ago

Closed 2 years ago

#9782 closed defect (fixed)

SCI: Game detection crashes ScummVM

Reported by: g5ppc Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game:

Description

Using the 5/8/2017 daily build on Win32, with disc 1 of either
GK2 FRench, or Phantas1 FRench, the application GPFs when you browse
to the CD drive, and attempt to have ScummVM identify the game.

I don't know what would be of assistance here, so let me know.

Change History (4)

comment:1 Changed 2 years ago by g5ppc

Retested both of these on 5/11 build. I believe RESSCI.PAT not found appears in the console window before vanishing. Also, no crash dialog appeared (this time on Win7). The original report was 5/7 build on Win 8.1, which I recall a crash dialog appeared.

comment:2 Changed 2 years ago by g5ppc

Also made out 'unknown' on the first line of the console window before it vanished, so I think it is detecting an SCI-type game, but not the precise one before it does something crashy.

comment:3 Changed 2 years ago by csnover

Component: GUIEngine: SCI

Thank you for your report! I was able to reproduce this issue, which was caused by accidentally exhausting file descriptors in the SCI resource manager. A fix has been added in f44d8b6da69a1444c76fcbce28a834f2368ddf35 and will be available in daily builds 1.10.0git-3275 and later.

Please note, however, that you cannot add multi-CD games to ScummVM by pointing it to a single CD. You must follow the datafiles instructions to set up the game data properly on your hard drive.

comment:4 Changed 2 years ago by csnover

Owner: set to csnover
Resolution: fixed
Status: newclosed
Summary: Game detect GPFsSCI: Game detection crashes ScummVM
Note: See TracTickets for help on using tickets.