Opened 23 months ago

Closed 23 months ago

Last modified 23 months ago

#9776 closed defect (fixed)

SCI: Torin: Crash in Escarpa

Reported by: ADeadTrousers Owned by: csnover
Priority: high Component: Engine: SCI
Keywords: sci32 Cc:
Game: Torin's Passage

Description

I was using this guide for the playthrough:
http://www.gameboomers.com/wtcheats/pcTt/TorinPassWT.htm

On Step 39 "go down to tile altar" the game crashed with an access violation:
Access violation reading script.20700 buffer: 8010 + 2 > 8011 (abs: 8010 + 2 > 8011)!

I'm using ScummVM 1.10.0git3250-g23abcffbc5 (May 8 2017 15:00:31)
My operating System is Windows 10 64 bit but I'm using ScummVM in 32 bit.
The game is the CD version released by Pointsoft.
The language is german.
According to the help menu the game version is 1.0

wkr ADT

Change History (9)

comment:1 Changed 23 months ago by ADeadTrousers

I just tried it again after going through the game from my last savepoint with quick jump and it crashed just like before.

Sadly It seems I'm not able to upload files so I can't provide a savegame.

comment:2 Changed 23 months ago by ADeadTrousers

I found a "Patch" folder containing the file 20700.scr and many more. As far as I can remember these patches had to be applied after the original game setup. The description for the game files in the wiki doesn't mention any special treatment so I'm not sure if and where to place these patch files.

comment:3 Changed 23 months ago by csnover

Keywords: sci32 added; Crash Access Violation Script removed
Summary: Torin's Passage: Chrashing in EscarpaSCI: Torin's Passage: Chrashing in Escarpa

Thanks for your report! The Trac UI can be a bit confusing; you should be able to add attachments by clicking the “Attach file” button, which is just below the yellow ticket description box at the top of the page. If you continue to have trouble with attachments you may also post a link to the file on a file sharing service like Dropbox.

With regards to files, patch files inside a PATCHES directory are automatically applied by ScummVM. Is this the name of the folder in your release, or does it have a different name?

comment:4 Changed 23 months ago by csnover

Priority: normalhigh

comment:5 Changed 23 months ago by ADeadTrousers

By Default it's named "Patch" (lowercase, singular) on the CD-Rom I have.
Renaming the folder to "PATCHES" (uppercase, plural) or "Patches" (lowercase, plural) definitely changed something. Now I get an error immediatly after loading my previous save games.
I guess I've to start all over again :(

You should mention the PATCHES behaviour on the game files page in the wiki.

wkr ADT

comment:6 Changed 23 months ago by csnover

Resolution: fixed
Status: newpending

The "patch" directory has been added to the engine’s directory search in 9e839775b69607675aa9e7a7257611028f494bbf. This change will be available in builds 1.10.0git-3270 and higher.

You should mention the PATCHES behaviour on the game files page in the wiki.

This information is not normally relevant to ScummVM users; loading files patches normally requires no additional user intervention, but in this case patch loading failed because Pointsoft did something non-standard for some reason. Now that the patch directory is identified by ScummVM, it will automatically load patches from that location as well.

With the game patches being loaded correctly, please let me know if the game continues to crash here, or if the problem is resolved. Thanks!

comment:7 Changed 23 months ago by ADeadTrousers

Now it's working. Perfect. thanks.

comment:8 Changed 23 months ago by csnover

Owner: set to csnover
Status: pendingclosed

Thank you for verifying that this issue no longer occurs now that the game’s script patches are being loaded.

comment:9 Changed 23 months ago by csnover

Summary: SCI: Torin's Passage: Chrashing in EscarpaSCI: Torin: Crash in Escarpa
Note: See TracTickets for help on using tickets.