Opened 2 years ago

Closed 19 months ago

#9771 closed defect (fixed)

SCI: KQ6: Death sequence dialog line repeats indefinitely

Reported by: bgK Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: King's Quest 6

Description

ScummVM: a403523fafafdaed7148b4c4a43c8b27ecdc63e6
Game: King's Quest VI Dos CD English from GOG.com

After going too far into the water in the first scene (beach), Alexander dies. After the death sequence, the dialog line "Nothing like getting swept off your feet" repeats indefinitely.

Also, the dialog is too tall (see screenshot).

This did not happen with ScummVM 1.9.0.

Attachments (1)

Capture d'écran de 2017-05-07 19-13-21.png (67.4 KB) - added by bgK 2 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 2 years ago by m-kiewitz

Owner: set to m-kiewitz

Was caused by my change to the KQ6 subtitle + audio at the same time script patch (a46f3c1).
Thanks snover for bisect.

comment:2 Changed 2 years ago by m-kiewitz

Should be fixed by commit cadd89e675dbca906fb492fac4e4738bf646bf9e

Still now there will be a few message boxes, that will require a mouse click in case you use audio + subtitles at the same time.

Can you please play through the game right from the beginning, while having a breakpoint on that object enabled, so that we get a somewhat proper list of all occurrences and then maybe also add information if those subtitle boxes actually require a click or not.

Simply enter SCI-debugger by pressing Ctrl-Shift-D and then enter "bpx KQ6Print::say". Debugger will then trigger on every call to it. Simply press ESC to continue playing.

But instead of pressing ESC immediately, please enter the command "room" and also note down the room number. It would also be helpful to get exact information, when the subtitle happened.

comment:3 Changed 2 years ago by bgK

Thanks for the fix!

I'm sorry, but I have no intention of doing a full playtrough of KQ6 in the near future.

comment:4 Changed 19 months ago by m-kiewitz

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.