Opened 2 years ago

Closed 2 years ago

#9765 closed defect (fixed)

SCI: Hoyle 1: Crash at startup reading vocab 0

Reported by: Laylia27 Owned by: csnover
Priority: high Component: Engine: SCI
Keywords: Cc:
Game: Hoyle's Book of Games 1

Description

Game: Hoyle Official Book of Games: Volume 1 (DOS/English)
Platform: Win32
ScummVM version: 1.10.0git3248-ga40.523faf (May 7 2017 12:57:54)
Still works in release version 1.9.0.2

Upon launching Hoyle 1 ScummVM closes immediately.

Log reads as follows:

[2017-05-07 02:02:02] ScummVM 1.10.0git3248-ga403523faf (May 7 2017 12:57:54)
[2017-05-07 02:02:02] TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG
[2017-05-07 02:02:02] --- Log opened.
[2017-05-07 02:02:04] Access violation reading vocab.0: 198 + 1 > 198 (abs: 198 + 1 > 198)!
[2017-05-07 02:02:04] --- Log closed successfully.

Change History (3)

comment:1 by csnover, 2 years ago

Summary: Hoyle 1 Crash at startupSCI: Hoyle 1: Crash at startup reading vocab 0

comment:2 by OmerMor, 2 years ago

I can confirm this crash reproduce using hoyle1 dos, amiga and atari-st.

comment:3 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report. The vocab 0 file in this game seems to be damaged, or at least it does not appear to contain any actual vocabulary. The game does not appear to need this information to run, so I have added an early escape from parsing in commit 444b11b1bb7cc01cc26cdd61247eda536c2cb7d5 which should allow the game to load and run again. It is very possible that this is not a complete/proper fix, but it makes things no worse off than they were before (when the vocab parser would have just continued to read into adjacent memory). This fix will be available in daily builds 1.10.0git-3278 and higher.

Note: See TracTickets for help on using tickets.