Opened 2 years ago

Closed 2 years ago

#9762 closed defect (fixed)

SCI: KQ7: Video playback is incorrect

Reported by: esziarko Owned by: csnover
Priority: blocker Component: Engine: SCI
Keywords: sci32 Cc:
Game: King's Quest 7

Description

ScummVM Version: 1.10.0git3200-g23b6dbb (Apr 30 2017)
OS: Windows 10 x64
Game version: King's Quest 7 v2.00b CD/Windows/English

The .avi files used for the game's videos in the Windows version are not being shown correctly (at least not the intro). The video is not in the frame, but instead only a small portion of what should be there is shown (see the screenshots for a comparison). The colors are also not displayed correctly as compared to playback in a normal media player.

The .rbt videos used by the DOS version are played fine.

Attachments (2)

scummvm00000.bmp (900.1 KB) - added by esziarko 2 years ago.
playback of the introduction .avi file in ScummVM
INT08X11.AVI_snapshot_00.08.jpg (13.0 KB) - added by esziarko 2 years ago.
How it should look, from playback in MPC.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by esziarko

Attachment: scummvm00000.bmp added

playback of the introduction .avi file in ScummVM

Changed 2 years ago by esziarko

How it should look, from playback in MPC.

comment:1 Changed 2 years ago by csnover

Keywords: sci32 added; video removed

comment:2 Changed 2 years ago by esziarko

Small update on this -- the issue is fixed if you go into a game and change the video option to Full, and then save the game. If you play the intro from the main menu then it'll look as it should.

comment:3 Changed 2 years ago by agfor

I saw the same problem.

comment:4 Changed 2 years ago by csnover

Priority: normalblocker

comment:5 Changed 2 years ago by csnover

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report! A fix for this problem has been added in commit 8cb35442c073b5ed5a0f3fa7d5e627bdd85af229 and will be available in daily builds 1.10.0git-3728 and higher.

Note: See TracTickets for help on using tickets.