Opened 2 years ago

Closed 2 years ago

#9748 closed defect (worksforme)

SCI: SQ6: Random lockups

Reported by: Zeith78 Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Space Quest 6

Description

There seems to be random lockups happening in the game where the game stops responding to input. Animations, music and ambient sound effects are still acitve and playing, but you can't do anything. Only way to fix it is to restart ScummVM and load a savegame.

Change History (5)

comment:1 by Zeith78, 2 years ago

ScummVM version: 1.10.0git3185-g519719db46
Language: English
Game version: CD
Platform: Windows 10 x64 1703

comment:2 by csnover, 2 years ago

Summary: SCI32: Space Quest 6 Random lockupsSCI: SQ6: Random lockups

Thanks for your report! I have a couple questions:

  • When you get stuck, is the cursor a “wait” cursor, or is the normal game cursor?
  • Does the game’s mouse cursor still move, or is it stuck in one place?
  • Can you still interact with the controls at the bottom of the screen when the game is stuck?
  • Do you have a save game that you can attach that demonstrates the issue? (If the game itself is non-responsive, try pressing ctrl+shift+d to enter the debugger and then type save_game <filename> to create a save named <filename> in the ScummVM savegames directory.)

comment:3 by csnover, 2 years ago

Keywords: sci32 added

comment:4 by Zeith78, 2 years ago

When I get stuck its usually the "normal" cursor, but it cant be changed. Changing it with the mouse buttons or the Verb-bar does not work.
I can move the mouse around but cant interact with anything.
No, the controls at the bottom does not work.
Sadly I dont have a savegame as I cant access the save menu when it happens. It hasnt happened that often, 3 or 4 times in total. I will try and reproduce it and use the debugger to make a save.

comment:5 by csnover, 2 years ago

Owner: set to csnover
Resolution: worksforme
Status: newclosed

Thanks for your report! Since this issue has been open for 3 months with no additional information to reproduce this bug, I am going to close this ticket for the moment and assume this is no longer an issue in current builds of ScummVM. If you encounter this issue in the future, please feel free to comment or reopen this ticket, with reproduction instructions if possible.

Note: See TracTickets for help on using tickets.