Opened 2 years ago

Last modified 18 months ago

#9746 new defect

SCI: Shivers: Wood Ixupi theme just wont stop

Reported by: GeekZolda Owned by:
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Shivers 1

Description

Tried the game twice, and both time, I had this issue where once I encounter the wood ixupi, it's theme music just loops and loops even if I leave the room or encounter other ixupi. I havent played tons yet, but I had no issue with the Ash Ixupi, Water Ixupi or Crystal Ixupi. Only with Wood.

Attachments (2)

shivers-win.003 (33.5 KB) - added by GeekZolda 2 years ago.
Save in the workshop, before the bug happens. May take some fiddling around (approaching the ixupi, leaving, approaching again) until the bug "works"
shivers-win.004 (33.2 KB) - added by GeekZolda 2 years ago.
Save after the bug happened, the wood ixupi theme should be looping wherever you go.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 2 years ago by m-kiewitz

Summary: Shivers - Wood Ixupi theme just wont stopSCI32: Shivers - Wood Ixupi theme just wont stop

comment:2 in reply to:  description Changed 2 years ago by GeekZolda

Some additional information, I only encountered the issue when confronting the wood ixupi in the workshop style area (next to Dr Windlenot's office's fireplace)

Replying to GeekZolda:

Tried the game twice, and both time, I had this issue where once I encounter the wood ixupi, it's theme music just loops and loops even if I leave the room or encounter other ixupi. I havent played tons yet, but I had no issue with the Ash Ixupi, Water Ixupi or Crystal Ixupi. Only with Wood.

comment:3 Changed 2 years ago by csnover

Keywords: sci32 added; sound issue removed
Summary: SCI32: Shivers - Wood Ixupi theme just wont stopSCI: Shivers: Wood Ixupi theme just wont stop

Thank you for your report! Do you have a save game at the point where this happens that you could provide? Since the locations of the ixupi are semi-random, this would help resolve the problem more quickly.

Changed 2 years ago by GeekZolda

Attachment: shivers-win.003 added

Save in the workshop, before the bug happens. May take some fiddling around (approaching the ixupi, leaving, approaching again) until the bug "works"

Changed 2 years ago by GeekZolda

Attachment: shivers-win.004 added

Save after the bug happened, the wood ixupi theme should be looping wherever you go.

comment:4 Changed 2 years ago by csnover

Thank you for the save games. I was able to reliably reproduce the bug. There seems to be a specific pattern you have to walk around in the room in order to trigger the bug, along with some quick movement.

  1. Go to the far end of the workroom.
  2. Stand at the short end of the worktable in the middle of the room, facing the door. There is a navigation hotspot to the left, over the crate.
  3. Click on the hotspot to navigate to the crate. You will hear the creaking noise.
  4. Turn twice to the right.
  5. Walk forward.
  6. Turn twice to the right. You will hear the Ixupi music.
  7. Walk forward. You will hear the creaking noise again.
  8. Turn twice to the right again.
  9. Walk forward once.
  10. Turn left once.
  11. Walk forward once.
  12. Run to the door. (Once you get to the door, if the music is still playing, it won’t stop playing.)

You now have an Ixupi soundtrack to your life.

You can get rid of the Ixupi soundtrack to your life as long as the Ixupi is still in the workroom by going back into the room and walking to the screen where the Ixupi music starts to play. (You will probably also be able to get rid of it once you encounter the Ixupi in another location that plays the same music.)

I suspect this is a game script bug that will also occur in the original interpreter but I have not verified this yet.

comment:5 Changed 2 years ago by GeekZolda

If it's a bug on the original game I never encountered it. Shivers was the first game I bought with my own money and I played it to death back then.

Maybe I was lucky !

comment:6 Changed 20 months ago by csnover

Owner: set to csnover
Resolution: worksforme
Status: newpending

I’m having trouble reproducing this issue lately, so I am wondering if additional fixes and improvements to the engine have transiently resolved this bug. Are you able to reproduce the problem using a recent daily build?

comment:7 Changed 20 months ago by csnover

Owner: changed from csnover to GeekZolda

comment:8 Changed 18 months ago by dafioram

Resolution: worksforme
Status: pendingnew

This is still in the current master.
ScummVM: 2.0.0git-81-gc278677d07 (Nov 28)
Build: Kirben Win32

Steps from save 3:

  1. Walk all the way to the wood statue in the box.
  2. Turn around and leave.

The soft wood tapping sound of the wooded Ixupi will continue to play in the background.

comment:9 Changed 18 months ago by dafioram

Owner: GeekZolda deleted
Note: See TracTickets for help on using tickets.