Opened 2 years ago

Closed 2 years ago

#9736 closed defect (fixed)

SCI: GK1: Napoleon House ambient audio stops playing when door audio plays

Reported by: DustyShinigami Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 1

Description

Whenever the sound effect for the door plays - when Gabriel enters and leaves - it causes the ambient sound effect of the patrons chattering to disappear. Talking to Stonewall King and exiting the conversation resumes the chattering until opening the door.

ScummVM version - 1.10.0git3185-g519719db49
Language of game - English
Version of game - Talkie, CD-ROM
Platform and Compiler - Win32

Attachments (1)

gk1-cd-win.002 (47.6 KB ) - added by DustyShinigami 2 years ago.

Download all attachments as: .zip

Change History (7)

by DustyShinigami, 2 years ago

Attachment: gk1-cd-win.002 added

comment:1 by csnover, 2 years ago

Summary: Gabriel Knight 1 - Napoleon House ambience glitchSCI: GK1: Napoleon House ambient audio stops playing when door audio plays

Thanks for your report!

This is related to the use of the old SCI16 digital audio code in SCI2 games, instead of the SCI32 digital audio code used by SCI2.1 and later. The old code is only capable of playing back a single digital audio sample at a time, and it permanently interrupts whatever sample is already playing when a new sample is played (instead of mixing, or restoring the old sample after the new one has finished). Some more RE needs to be done on GK1 audio code to figure out what the right thing to do is.

comment:2 by DustyShinigami, 2 years ago

I see. Not sure if they're related, but what about the music that plays on the map? That seems to play in conjunction with the ambient sounds of traffic and bustling people.

comment:3 by DustyShinigami, 2 years ago

Reloading a save on the map only plays the music. No ambient sounds of traffic etc.

comment:4 by csnover, 2 years ago

Keywords: sci32 added

comment:5 by csnover, 2 years ago

Sorry for the delay in answering your question. Most of the audio problems you’ll encounter in GK1 will have the same root cause for now (wrong audio code), but please continue to report them as you notice them (in new tickets) so we can check to verify all bugs are fixed once updated audio code is implemented.

comment:6 by csnover, 2 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed

Thanks for your report! A patch for this issue was added in d556dcc57bf50a03d81ab7a1ef59a9e5758465bf and will be available in builds 1.10.0git-3493 and later.

Note: See TracTickets for help on using tickets.