Opened 3 years ago

Closed 6 months ago

#9735 closed defect (fixed)

SCI: GK1: Jingle when receiving game score points is missing

Reported by: DustyShinigami Owned by: ZvikaZ
Priority: normal Component: Engine: SCI
Keywords: sci32, midi Cc:
Game: Gabriel Knight 1

Description

Just started testing Gabriel Knight 1 with the latest daily ScummVM build and I've noticed there's no jingle when picking up items.

ScummVM version - 1.10.0git3185-g519719db49
Language of game - English
Version of game - Talkie, CD-ROM
Platform and Compiler - Win32

Attachments (1)

gk1-cd-win.001 (45.0 KB ) - added by DustyShinigami 3 years ago.

Download all attachments as: .zip

Change History (11)

by DustyShinigami, 3 years ago

Attachment: gk1-cd-win.001 added

comment:1 by DustyShinigami, 3 years ago

Looks like the issue is only at St. George's Books so far.

comment:2 by csnover, 3 years ago

Summary: Gabriel Knight 1 - No JingleSCI: GK1: No Jingle

Thanks for your report! I was able to reproduce the missing chime only when using General MIDI (Adlib and MT-32 seemed to work correctly). Could you verify which music mode you are using?

comment:3 by DustyShinigami, 3 years ago

I'll try that. I use Microsoft GS Wavetable Synth (Windows MIDI).

comment:4 by csnover, 3 years ago

Keywords: sci32 added

comment:5 by DustyShinigami, 3 years ago

As well as St. George's Books, that jingle isn't present in the Napoleon House either. Again, I'm using Microsoft GS Wavetable Synth (Windows MIDI).

comment:6 by csnover, 3 years ago

Summary: SCI: GK1: No JingleSCI: GK1: Jingle when receiving game score points is missing

comment:7 by csnover, 3 years ago

Keywords: midi added

comment:8 by csnover, 3 years ago

Owner: set to csnover

comment:9 by digitall, 23 months ago

Owner: csnover removed

comment:10 by bluegr, 6 months ago

Owner: set to ZvikaZ
Resolution: fixed
Status: newclosed

This should be fixed with pull request 2074:
https://github.com/scummvm/scummvm/pull/2074

Note: See TracTickets for help on using tickets.