Opened 2 years ago

Closed 2 years ago

#9729 closed defect (fixed)

Music After Solving Rebel Tunnel Puzzle Doesn't Start with Cutscene

Reported by: dch216 Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

Current Daily Build: 1.10.0git3031-g910e6816ea (11 Apr 2017)

Game Version: English, 5-CD (contains v1.02 patch files)
Platform: Windows 10 (x64)

Bug details:

After successfully solving the rebel tunnel puzzle, the music that plays once the puzzle is solved should start along with the cutscene to match the draining of the water and the extension of the tray holding the book. Instead, the post-puzzle music doesn't start until after that cutscene.

Reproduction: Reach the rebel tunnel puzzle and push in the correct sequence of stones (Fish, Beetle, Frog, Sunner, and Whark). Music doesn't change when the cutscene starts and only incorrectly changes once the cutscene finishes.

Attachment: Save file that puts you at the rebel tunnel puzzle with all stones pushed in except for the last one (central Whark stone).

Attachments (1)

riven-000.rvn (15.7 KB) - added by dch216 2 years ago.
Rebel Tunnel Puzzle Save

Download all attachments as: .zip

Change History (4)

Changed 2 years ago by dch216

Attachment: riven-000.rvn added

Rebel Tunnel Puzzle Save

comment:1 Changed 2 years ago by macca8

Not an obvious glitch but I've confirmed it on Mac OS X, though my observations of the behaviour differ slightly to your report.

To clarify:

  • the cutscene begins with a screen flicker and ends with the appearance of the cursor (runs about 30 seconds).
  • only the cutscene is affected by this issue… the post-cutscene music IS correct.
  • the opening portion of the post-puzzle music is replaced by a continuation of the pre-cutscene music for the duration of the cutscene.
  • the music transitions seamlessly and correctly to the remaining portion of the post-puzzle music when the cutscene ends.

This suggests to me that the correct music starts when expected, but is overridden (for some reason) by the previous music while the cutscene is playing.

Based on my testing of older daily builds, the issue first appears sometime between 14 July 2016 (1.9.0git2710) & 17 August 2016 (1.9.0git4347), which includes changes to handling ambient sounds.

comment:2 Changed 2 years ago by dch216

The above description is a more accurate one as to the glitch that occurs. My original description missed the detail that once the cutscene ends the music does smoothly transition to the remaining portion of the post-puzzle music and incorrectly implies the post-puzzle music starts with the end of the cutscene.

comment:3 Changed 2 years ago by bgK

Owner: set to bgK
Resolution: fixed
Status: newclosed

This is fixed since the Riven engine overhaul from GitHub#966.

Note: See TracTickets for help on using tickets.