Opened 2 years ago

Closed 2 years ago

#9721 closed defect (worksforme)

Android version crashes on laboratory bench with German version

Reported by: Flexmaen Owned by: dreammaster
Priority: normal Component: Engine: Sherlock
Keywords: Cc:
Game: Sherlock Holmes: Case of the Serrated Scalpel

Description

There seems to be a Bug with "Sherlock Holmes: The Lost Files" (at least with the German Version).

I atteched a savegame, just at the situation where the problem takes place.

All you have to do there:
Benutze Pulverartige Substanz mit Labortisch (use powder with laboratory)
Benutze Pulverartige Substanz mit Reagenzglas (use powder with glass)
Benutze Streichhölzer (use matches)

The game will crash on my Android Tablet (Android 7.1) while this works fine on the Windows Version of ScummVM.

Attachments (3)

scalpel-de.000 (15.6 KB) - added by Flexmaen 2 years ago.
savegame where you can do the test on the laboratory table
scalpel-de.002 (14.6 KB) - added by Flexmaen 2 years ago.
crash on "Bewege Spundpfropfen"
scalpel-de.006 (18.1 KB) - added by Flexmaen 2 years ago.
crash when moving the upper box

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by Flexmaen

Attachment: scalpel-de.000 added

savegame where you can do the test on the laboratory table

Changed 2 years ago by Flexmaen

Attachment: scalpel-de.002 added

crash on "Bewege Spundpfropfen"

comment:1 Changed 2 years ago by Flexmaen

I attached a 2nd file. Here you'll have a crash if you do "Bewege Spundpfropfen" (="move plug", you find the plug in the barrel on the right side). If the girl starts talking you'll have to repeat the command.

Unlike the previous broblem with laboratory table, which has different results in the Windows and Android versions, this crash might be a bug of the game or a current version (since it also happens in DOS).

Changed 2 years ago by Flexmaen

Attachment: scalpel-de.006 added

crash when moving the upper box

comment:2 Changed 2 years ago by Flexmaen

Next attachment: When moving the upper box in the Tabacco shop ("Bewege Zigarrenkiste") the game crashes too.

I tried to play it in the dosbox, there it worked.

comment:3 Changed 2 years ago by dreammaster

For the laboratory error, I too don't have any problem on the Windows version. I'm at a loss why it would crash on the Android for you and not in Windows. Maybe a bad transfer of the game's datafiles. Otherwise, I think I'll have to rely on any other developer familiar with Android to have a look, since it can't be replicated under Windows.

For the second, item, trying to move the plug of the barrel outside the pub, it works fine for me. The flower girl, Lesley, responds with "Ich brauche der Wasser fur meine Blumen, Sir. Bitte kippen Sie es nicht aus!". The only two things I can think of why my version would work and yours crash is that we might have two different releases of the German, and it was a problem they fixed for my release. Or you may have got an accidental corruption copying from your original discs. I'd suggest recopying the datafiles from your original disc, and if that doesn't fix the problem, try using an md5 tool to create md5 hashes of all your gamefiles. I could then compare it against mine to see if there any differences between our two copies.

As for the third one, I couldn't replicate any problem either. Though I do remember fixing a crash for that very problem in the German version a while back. What version of ScummVM are you using? You never said. Try downloading and running a daily build, and see if you still have the problem.

comment:4 Changed 2 years ago by Flexmaen

You can find the version I used in that forum thread: http://forum.scummvm.org/viewtopic.php?t=14306
For ScummVM I used 1.9.0.
I'll check with the latest nightly. Either the copy of Sherlock is corrupted or it is an older version that was fixed later. However I wonder if this should result in a crash of ScummVM, or in different behaviour within Windows and Android versions (both 1.9.0).

comment:5 Changed 2 years ago by dreammaster

Owner: set to dreammaster
Resolution: worksforme
Status: newclosed

It seems from the forum thread that you don't have a legitimate version of the game. As such, I'm sorry, but I can't provide any further assistance. I do know that the things in your bug report are working correctly for me on the most recent ScummVM version with legitimate data files, so I'm closing this bug as Works For Me.

Note: See TracTickets for help on using tickets.