Opened 3 years ago

Closed 12 months ago

#9719 closed defect (worksforme)

Crashes and no sound in fullscreen mode

Reported by: LuismaSP89 Owned by: digitall
Priority: normal Component: --Other--
Keywords: Cc:
Game:

Description

When i enter in fullscreen mode, all sounds and music mute. And when i try to exit, scummvm crashes. This happens with all graphic modes, the OpenGL is the only one that is working. But OpenGL looks fuzzy compared with the other filters.

Other users report this:

http://forums.scummvm.org/viewtopic.php?t=11536

It seems that the problem is with the Nvidia HD audio. It doesn´t support the low resolution of the screen with these filters and stops the audio device.

There would be a fix in future for this? For example use an Opengl+6xbrz, hq5x, stretched mode, etc.

Thanks a lot and sorry for my english.

Change History (2)

comment:1 by csnover, 2 years ago

Keywords: Fullscreen Audio removed
Owner: set to LuismaSP89
Resolution: worksforme
Status: newpending
Type: enhancementdefect

This should not be an issue with SDL2, which uses desktop fullscreen mode so does not cause any hardware mode switch. Could you please follow the instructions at https://bugs.scummvm.org/ and fill out this ticket with missing information about ScummVM and SDL version? Thanks!

Version 0, edited 2 years ago by csnover (next)

comment:2 by digitall, 12 months ago

Owner: changed from LuismaSP89 to digitall
Status: pendingclosed

Since the original bug submitter has not provided any further update for nearly a year, and this may be an issue with their OS OpenGL drivers / earlier versions of SDL2, I am going to close this as WORKSFORME.

If we get new information on this, this can be reopened.

Note: See TracTickets for help on using tickets.