Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9715 closed defect (invalid)

Curse of Monkey Island won't load via cdrom mount on Linux

Reported by: hooby3dfx Owned by: hooby3dfx
Priority: normal Component: --Other--
Keywords: linux, cdrom, mount Cc:
Game: Monkey Island 3

Description

I think Linux directory detection has a bug when viewing files on a mounted cdrom.

This seems like a valid use case, and I expect the issue would affect other games as well.

Note that this works correctly on Windows.

Found in 1.9.0.

Steps to reproduce this:

  1. Insert COMI cdrom into Linux machine
  2. Mount the cdrom with:

mkdir cdmnt
mount -t iso9660 /dev/cdrom cdmnt/

  1. Open ScummVM
  2. Click Add Game menu
  3. Navigate to the cdmnt folder and enter it
  4. Note that the directories (ex 'resource' folder) do not appear as folders (they look like other files).
  5. The game will add and detect, but when launching will fail with "scummvm error cant open bundle file musdisk1.bun" (that file is in the resource folder)
  6. When copying the files from the disc to a directory on the computer, directories such as resource and install folders appear correctly and can be entered. The game locale is also detected correctly and it can be launched.

I suspect the cause of this is due to the file system link count.
ls -al cdmnt
total 68678
dr-xr-xr-x 1 root root 2048 Oct 16 1997 .
drwxr-xr-x 5 root root 1024 Mar 9 04:14 ..
-r-xr-xr-x 1 root root 41 Jul 22 1997 autorun.inf
-r-xr-xr-x 1 root root 76791 Oct 15 1997 comi.la0
-r-xr-xr-x 1 root root 69340645 Oct 15 1997 comi.la1
-r-xr-xr-x 1 root root 628736 Oct 13 1997 curse.exe
dr-xr-xr-x 1 root root 4096 Oct 10 1997 directx
dr-xr-xr-x 1 root root 2048 Oct 10 1997 install
-r-xr-xr-x 1 root root 5597 Oct 13 1997 launcher.tab
-r-xr-xr-x 1 root root 213504 Oct 14 1997 monkeytg.doc
-r-xr-xr-x 1 root root 34652 Oct 14 1997 monkeytg.txt
-r-xr-xr-x 1 root root 13474 Oct 15 1997 readme.txt
dr-xr-xr-x 1 root root 2048 Oct 10 1997 resource

ls -al comicopy
total 68676
dr-xr-xr-x 5 root root 1024 Mar 9 04:16 .
drwxr-xr-x 3 root root 1024 Mar 9 04:14 ..
-r-xr-xr-x 1 root root 41 Mar 9 04:14 autorun.inf
-r-xr-xr-x 1 root root 76791 Mar 9 04:14 comi.la0
-r-xr-xr-x 1 root root 69340645 Mar 9 04:15 comi.la1
-r-xr-xr-x 1 root root 628736 Mar 9 04:15 curse.exe
dr-xr-xr-x 3 root root 3072 Mar 9 04:16 directx
dr-xr-xr-x 2 root root 1024 Mar 9 04:16 install
-r-xr-xr-x 1 root root 5597 Mar 9 04:16 launcher.tab
-r-xr-xr-x 1 root root 213504 Mar 9 04:16 monkeytg.doc
-r-xr-xr-x 1 root root 34652 Mar 9 04:16 monkeytg.txt
-r-xr-xr-x 1 root root 13474 Mar 9 04:16 readme.txt
dr-xr-xr-x 2 root root 1024 Mar 9 04:22 resource

Change History (2)

comment:1 by hooby3dfx, 3 years ago

Owner: set to hooby3dfx
Resolution: invalid
Status: newclosed

My mistake, this issue was actually found on a fork of scummvm and its their bug!

comment:2 by wjp, 3 years ago

Ok, thanks for following up; I had tried to reproduce it myself with a cdemu device in ScummVM, but failed to.

Note: See TracTickets for help on using tickets.