Opened 2 years ago

Last modified 2 years ago

#9708 new defect

R2R: Return to Ringworld save game progress no longer works

Reported by: Alien-Grey Owned by:
Priority: normal Component: Engine: TsAGE
Keywords: Cc: Alien-Grey
Game: Return to Ringworld

Description

It isn't possible to save the Return to Ringworld game progress. Pressing F5 to save the game does nothing.

I'm using the latest daily stable build for Windows 11 64 Bit.

Change History (11)

comment:1 Changed 2 years ago by dreammaster

Summary: Return to Ringworld save game progress no longer worksR2R: Return to Ringworld save game progress no longer works

I just tried on my local machine, running Windows 8.1, and the keys work correctly. Are you using any special keyboard layout? You might also want to try and see if Ctrl+F5 correctly brings up the ScummVM Global Main Menu. Worst case, you can always right-click, and select the options button to bring up the in-game Options menu, which has buttons for saving and loading.

comment:2 Changed 2 years ago by Alien-Grey

It should've been Windows 10 but made a typo.

I tried both ways and I can't get to the save menu. All other options do work in the in-game options menu. This isn't the only issue I've got with this game. It seems that the only way to get the game running without crashing is to use no scaler. I'm not sure if using no scaler isn't going to make the game crash after some time playing because I didn't test it long enough.

I've finished playing Ringworld - The revenge of the Patriarch and it also made the game crash several times with Windows 10.

Both games seem to suffer from low fps when using scalers and there's also always a clicking sound.

comment:3 Changed 2 years ago by Alien-Grey

Cc: Alien-Grey added

Maybe it's also important to tell you that SCUMM games do run just fine with scalers. I've finished The Dig without issues and I've started playing Indiana Jones and the Fate of Atlantis.

comment:4 Changed 2 years ago by Alien-Grey

Ctrl+F5 does work to go to the ScummVM Global Main Menu. I've got to use an extra key to use F5.

I've tried Return to Ringworld on my PC with Windows 7 X64 and didn't have any issue except saving from the in-game option menu also doesn't work and pressing F7 to show the credits makes the game crash.

I've tried Return to Ringworld with default settings on Windows 10 but also got the program isn't responding after a few minutes playing the game. The clicking noise I'm hearing is like the sound going on and off.

comment:5 Changed 2 years ago by dreammaster

This all sounds very weird. Are the F5 and F7 keys (F7 is restore, by the way, not credits, which is F8) at least bring up the ScummVM Save/Restore dialogs. i.e. is it that the dialogs aren't opening at all, or that you're getting error when you've actually entered a savegame name and it tries to save? R2R does have it's own save dialog, so the handling for the F5/F7 is pretty basic to simply open up the dialogs, so I can't imagine why the keys on their own wouldn't work to at least bring up the dialogs, unless you try to press them in the middle of a cutscene.

I tried playing it myself for a little while with a 3x scaler just to see if I could replicate any problem with hanging or crashes, and I couldn't. I vaguely remember there's an outstanding bug for sound hanging, but it happened so rarely that it was never able to be investigated further.

comment:6 Changed 2 years ago by dreammaster

Though, one thing I did find as a result of this testing is that if you press the F8 key for credits whilst the credits are already active, you get into an infinite loop of credits and can never escape them :)

comment:7 Changed 2 years ago by Alien-Grey

A partial fix for my Windows 10 device is to go back to ScummVM 1.7.0. I'm saying partial because I did get the program is not responding but couldn't replicate it by going back with a save game and trying it again. But at least the game is playable with this version on my Windows 10 device. Going to the save menu with pressing F5 in the in-game option menu doesn't work but Ctrl+F5 does.

I meant pressing F8 from the in-game option menu to bring up the credits. I'm getting a black screen on both my Windows 7 X64 and Windows 10 X64 with the latest stable and development ScummVM release. This does work with ScummVM 1.7.0.

To investigate this bug you should try to use OpenGL as scaler. If I'm using OpenGL as scaler I can't get past the intro without the game to hang and Windows 10 complaining that the program doesn't respond.

comment:8 Changed 2 years ago by dreammaster

I tried using the OpenGL scaler as you suggested, and didn't encounter any problems with the intro, sorry. If anyone else reading this bug thread has a copy of Return to Ringworld, I'd be interested in another test to see whether it works for them or not.

It's weird, but I simply can't replicate any of the problems you've experienced. Well, at least from what you've said, you're able to use the earlier version on your system, so that's something at least.

comment:9 Changed 2 years ago by Alien-Grey

I finished the game with ScummVM 1.7.0 on my Windows 10 device. I did get the program isn't responding in the beginning of the game when you.ve got to disable the stasis field from the hyperdrive. It was the only time that Windows 10 complained about it while playing the game.I did get the crash again in the vampire lair but I've got no idea what's causing this bug. I could exit it after replaying it 3 times.

I also noticed that when you have to walk in to the light beam at the end of the game and you don't use Quinn it pops up the ScummVM console.

I don't know why Windows 10 complaints about the program not responding on my device with latest builds but maybe it has something to do with the syncing the audio and video. It looks to me like when using OpenGL as a scaler with the latest build that the audio and video is out of sync.

comment:10 Changed 2 years ago by wjp

Interesting. The not-responding would typically be a result of the event loop not being run, although at least for me that is happening regularly.

Do you have a specific example (+ savegame?) for a scene where audio/video sync is wrong?

comment:11 Changed 2 years ago by Alien-Grey

I don't have a save game but you don't really need it. I cna notic it as soon as the Tsuname intro is playing with OpenGL as scaler. The video seems to run faster than the audio. Afetr playing the Tsunami intro Windows 10 gives me the program isn't responding with OpenGL as scaler on mu device.

Note: See TracTickets for help on using tickets.