Opened 4 years ago

Closed 4 years ago

#9706 closed defect (fixed)

PQ1AGI: Broken save game at cards game

Reported by: waltervn Owned by: m-kiewitz
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Police Quest 1

Description

Broken save game when saving right before the high stakes card game switches to the poker screen. The game is frozen when the game is restored. My guess is that it is waiting for the music to stop, but the music is not playing.

Steps to reproduce:

  • Sit down at the high stakes card game
  • Quickly press enter to close the text messages
  • Save the game while the music is playing
  • Restore this save game

I was unable to reproduce this in the original interpreter. It goes straight to the card game both after saving and restoring.

Save games attached for PQ1 2.0G DOS version.

Attachments (2)

pq1.100 (3.2 KB ) - added by waltervn 4 years ago.
pq1.101 (3.2 KB ) - added by waltervn 4 years ago.

Download all attachments as: .zip

Change History (5)

by waltervn, 4 years ago

Attachment: pq1.100 added

by waltervn, 4 years ago

Attachment: pq1.101 added

comment:1 by m-kiewitz, 4 years ago

Owner: set to m-kiewitz

Please check, if this still happens after applying commit be763b5.
It could have been caused by the very same bug.

comment:2 by waltervn, 4 years ago

This still happens

comment:3 by m-kiewitz, 4 years ago

Resolution: fixed
Status: newclosed

fixed by commit 77d232f

It's probably still possible to trigger this via GMM saving, but that needs to get fixed differently.

Note: See TracTickets for help on using tickets.