Opened 3 years ago

Last modified 3 months ago

#9704 pending defect (worksforme)

WME: Reversion 1+2 Font issues with installed font

Reported by: windlepoons Owned by: windlepoons
Priority: normal Component: Engine: Wintermute
Keywords: Cc:
Game: Wintermute

Description

ScummVM 1.10.0git2269-gbc08f9a (Feb 9 2017 05:23:39)
OS: Siduction (based on Debian/sid) x86_64 GNU/Linux
Game version: Steam Windows (installed under wine)

The installed font (YanoneKaffeesatz-Regular.ttf) from Reversion 1+2 has some issues with Umlaut, ß and incorrect text spacing.
The YanoneKaffeesatz-Regular.ttf is not the original Yanone Kaffeesatz font from yanone.de.

Steam does not install fonts with the game and can good read the text.
My suggestion would be ScummVM ignore the font folder into the root of the Reversion games.

In the attachment you can compare some screenshots.

Attachments (2)

reversion_font.png (466.8 KB ) - added by windlepoons 3 years ago.
reversion_font_2019.png (112.9 KB ) - added by lolbot-iichan 3 months ago.

Download all attachments as: .zip

Change History (5)

by windlepoons, 3 years ago

Attachment: reversion_font.png added

comment:1 by windlepoons, 3 years ago

I correct:
The Linux Steam version from reversion does not install the font folder.
The Windows version from Steam install this, but the game ignored this fonts.

comment:2 by windlepoons, 3 years ago

This issues is fixed with reported checksums. Currently, this is not the case.

by lolbot-iichan, 3 months ago

Attachment: reversion_font_2019.png added

comment:3 by lolbot-iichan, 3 months ago

Owner: set to windlepoons
Resolution: worksforme
Status: newpending

Could not reproduce with latest ScummVM and Steam version of Reversion.
Screenshot attached: ScummVM + Reversion with fonts folder.

Note: See TracTickets for help on using tickets.