Opened 3 years ago

Closed 3 years ago

#9696 closed defect (fixed)

SCI: KQ7: Harp in Etheria hangs game

Reported by: csnover Owned by: csnover
Priority: high Component: Engine: SCI
Keywords: sci32 Cc:
Game: King's Quest 7

Description

Reproduction:

  1. Load attached save game
  2. Press the harp strings in the correct sequence (from left, 1 5 6 4)

Expected: Entire harp animation plays successfully
Actual: Animation gets stuck on state 7

The affected object is the cloned finishTune. This is the only bug in KQ7 that prevents game completion.

Game version: Windows 2.00b

Attachments (1)

kq7-cd-win.003 (63.7 KB ) - added by csnover 3 years ago.

Download all attachments as: .zip

Change History (4)

by csnover, 3 years ago

Attachment: kq7-cd-win.003 added

comment:1 by wjp, 3 years ago

This looks like another instance of our mishandling of signals at the beginning of tracks. We miss a signal there in this song. A similar workaround to the EcoQuest 2 room 530 one in MidiParser_SCI::parseNextEvent should suffice until we properly fix this...

comment:2 by csnover, 3 years ago

Owner: set to csnover

comment:3 by csnover, 3 years ago

Resolution: fixed
Status: newclosed

Fixed in 5723f2f5feb4dc0b51423e7d03c6fc05dc201c9e.

Note: See TracTickets for help on using tickets.