Opened 10 months ago

Closed 9 months ago

#9674 closed defect (fixed)

SCI: QFG3: Broken day/night cycle stuck on daylight

Reported by: salty-horse Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Quest for Glory 3

Description

At one point in the game, it shifts to day and never changes back to night.

The bug was originally mentioned in a podcast - I did not see it myself. I have since obtained savegames showing the problem (attached). It was also mentioned on the forums in 2014

I am not sure if this is a bug in the original that is exposed by ScummVM, or a ScummVM bug.

Attachments (1)

qfg3endlessdaybug.zip (113.1 KB) - added by salty-horse 10 months ago.
Savegames showing the problem

Download all attachments as: .zip

Change History (4)

Changed 10 months ago by salty-horse

Attachment: qfg3endlessdaybug.zip added

Savegames showing the problem

comment:1 Changed 10 months ago by wjp

The reason the palette is not changing in this savegame is that _palVaryPaused somehow seems to be equal to 3 (instead of 0), so the night-time palette change is stuck in a paused state.

I'm unsure how this happened, but one thing that seems fishy is that restoring doesn't reset the palVary state, unless the game that's being loaded has _palVaryResourceId != -1

comment:2 Changed 10 months ago by wjp

Here's one way of reproducing the problem:

When going to the bazaar during twilight, the function bazaarR::init (script 51) pauses the palvary. If you then use the ScummVM menu at Ctrl-F5 to load a game that does not have an active palvary, _palVaryPaused stays stuck at 1. This should be repeatable to get it to 3.

The QfG3 scripts seem to always try to ensure to that palvary is unpaused when saving or loading. But using the Ctrl-F5 menu to load bypasses this.

Random note, unrelated to this bug: if the twilight effect is (normally) paused while visiting the bazaar, entering and closing (scripted) dialogs (such as the game's load/save/settings menu) will un-pause the twilight effect. This happens in SSCI too. (But fixing that script issue in SSCI might not have been straightforward due to the interaction with saving/loading at twilight.)

comment:3 Changed 9 months ago by csnover

Owner: set to wjp
Resolution: fixed
Status: newclosed

Fixed in 740b0bb0ca1585e1eff49afe8da1104830cc1e02.

Note: See TracTickets for help on using tickets.