Opened 2 years ago

Closed 2 years ago

#9648 closed defect (fixed)

SCI: GK2: Inventory jumps in the wrong direction at the start of scroll

Reported by: bgK Owned by: csnover
Priority: low Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 2

Description (last modified by csnover)

In the inventory panel, clicking the down arrow scrolls one pixel in the wrong direction before scrolling in the correct direction.

Reproduction:

  1. Load save game
  2. Open inventory
  3. Press the down arrow in the inventory

Expected: Inventory only scrolls down
Actual: Inventory jumps a pixel upward before scrolling in the correct direction

Game version: 1.00 and 1.01

Change History (7)

comment:1 Changed 2 years ago by bgK

The saved game is too big to attach to the tracker. Here it is:
https://filenurse.com/download/64b6d3c583b3bbbd9a18f890a751ff32.html

The bug happens as soon as there are enough inventory items, using this particular save has no importance.

(The saves being very large is probably another bug. Their size seem to increase as progress in the game is made.)

comment:2 Changed 2 years ago by csnover

Keywords: sci32 added
Owner: set to bgK

The file you uploaded expired and is no longer available. Could you please upload it again?

comment:4 Changed 2 years ago by csnover

Something is definitely broken with the way this works in ScummVM (it shouldn’t ever be moving in the wrong direction as it is now), but the arrows are intended to be held down; the inventory does scroll successfully if you just hold down the mouse button instead of clicking.

comment:5 Changed 2 years ago by csnover

Owner: changed from csnover to m-kiewitz
Resolution: wontfix
Status: newpending

As it turns out, the jump up occurs in SSCI as well, but since it scrolls as fast as the game scripts can run, you are unlikely to notice it unless you turn cycles in DOSBox way down (to like 15%).

It may be possible to script patch whatever script is responsible for the janky scroll but it’s such a cosmetic problem that I don’t feel like investing time or energy in it. m-kiewitz, I know you have interest in script patching bugs, so if you would be interested in writing a patch for this bug then the ticket can stay open, otherwise I think it should be closed wontfix.

comment:6 Changed 2 years ago by csnover

Description: modified (diff)
Priority: normallow
Summary: SCI: GK2: Unable to scroll the inventorySCI: GK2: Inventory jumps in the wrong direction at the start of scroll

comment:7 Changed 2 years ago by csnover

Owner: changed from m-kiewitz to csnover
Resolution: wontfixfixed
Status: pendingclosed
Note: See TracTickets for help on using tickets.