Opened 4 years ago

Closed 3 months ago

#9647 closed defect (worksforme)

CINE: FW - Mouse requires long/multiple clicks to register

Reported by: superjamie Owned by: karisal
Priority: normal Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

ScummVM version (scummvm -v)

ScummVM 1.9.0 (Oct 22 2016 10:21:00)

Bug details, including instructions on reproducing

Play Future Wars (fw). Mouse clicks do not "register" being pressed as easily as they do in the ScummVM menus, or in other games.

Mouse clicks either require to be pressed for a long time (like 1 second) or pressed multiple times to register.

This can be reproduced on the first copy protection screen as soon as the game starts, and at all times during regular gameplay.

Language of game (English, German, ...)

English

Version of game (Talkie, Floppy, ...)

DOS Floppy displays this problem quite badly.
Amiga and Atari ST versions are not as bad, but the problem is still present.

Platform and Compiler (Win32, Linux, ...)

Tested using scummvm.org Ubuntu 16.04 package on Ubuntu 16.04 64-bit

Also tested using scummvm.org Win32 installer thru Wine, same thing occurs.

Attach a save game if possible

No savegame is required to reproduce this issue.

If this bug only occurred recently…

Tested with Ubuntu's ScummVM 1.7.0 package, same issue occurs.

Tested with scummvm.org 1.8.0 Ubuntu Wily amd64 package, same issue occurs.

Doesn't appear to be a recent regression.

Additional Info

This is not noted on the compatibility page:
http://www.scummvm.org/compatibility/DEV/fw/

Couldn't see any listed TODO or Known Bug about this on the Cine page:
http://wiki.scummvm.org/index.php/Cine/TODO

This doesn't occur when emulating the game via DOSBox or Hatari.

Change History (3)

comment:1 by raziel-, 5 months ago

Summary: FW: Mouse requires long/multiple clicks to registerCINE: FW - Mouse requires long/multiple clicks to register

comment:2 by karisal, 4 months ago

These changes ("Make interface more responsive (See manageEvents() and drawFrame()).") may have affected this bug.

in reply to:  2 comment:3 by karisal, 3 months ago

Owner: set to karisal
Resolution: worksforme
Status: newclosed

Replying to karisal:

These changes ("Make interface more responsive (See manageEvents() and drawFrame()).") may have affected this bug.

I think these changes have fixed this bug so closing with status worksforme. I tried running Future Wars using the 2.2.0 branch on 31st of August, 2020 and it felt fine to me.

Feel free to reopen this ticket if you feel that it was closed in error - although I am quite confident it has not been. Thank you!

Note: See TracTickets for help on using tickets.