Opened 3 years ago

Closed 3 years ago

#9641 closed defect (fixed)

SCI: Shivers: Bulls and Cows puzzle, incorrect display of master tiles

Reported by: csnover Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Shivers 1

Description

Room 31090. The master tiles for the puzzle, when revealed, are displayed using the wrong cel numbers.

In the game for the attached screenshot the cel numbers are:

Expected Actual
12 8
18 16
12 10
3 2
12 11

This can be reproduced even without winning the game by clicking on the cover over the master tiles after pulling the lever.

Attachments (1)

581be91259762.png (100.5 KB ) - added by csnover 3 years ago.

Download all attachments as: .zip

Change History (4)

by csnover, 3 years ago

Attachment: 581be91259762.png added

comment:1 by csnover, 3 years ago

Similar problem happens if you lose the harp puzzle, some of the randomly illuminated harp strings remain illuminated after the failure animation.

comment:2 by csnover, 3 years ago

In at least the case of the Bulls and Cows puzzle, not clearing the -info- flag in ScreenItem::setFromObject prevents the problem. I’ve tried to find every place I can think of in disassembly where this flag gets set and cleared (searching for AND ? ? 8, OR ? ? 8), and haven’t been able to find any more differences in what we do versus SQ6. The only place I can imagine being wrong is _exec_varselectors/send_selector but it is hard to tell since the SSCI VM is implemented differently here.

This problem also manifests itself in Phant1; if you use the fast-forward button while Adrian is walking, she incorrectly does not jump to the end of the walk animation as she should. Phant1 disassembly seems to have the same number of instances of AND ? ? 8 and OR ? ? 8 as SQ6 disassembly, so while it is possible that something was changed between engines, a cursory examination seems to point toward there not being a change.

comment:3 by csnover, 3 years ago

Owner: changed from csnover to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.