Opened 2 years ago

Closed 2 years ago

#9638 closed defect (worksforme)

SCI: GK1: Wrong cursor in Jackson Square park

Reported by: sluicebox Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 1

Description

Sometimes the Walk cursor displays the wrong cursor in Jackson Square park. When walking in between the four rooms of the park, the new room will load and the cursor will change to something else and stay that way. I've seen it be the the Waiting cursor (the "GK" shield) and also the Open cursor (the door). It will keep functioning as Walk until mousing up to the menu or doing something like interacting with someone or leaving the park. I've seen this happen when when the mime follows you and also when you're walking back to the artist with his drawing. I haven't seen it happen when just walking around the park while nothing interesting is happening. I've never seen it happen in the original game.

I've attached a save game where it's about to happen. Walk to the mime to get him to follow you then walk south. When the southern room loads the cursor will become the Open cursor, but it's still in Walk mode. Walking east works too, but you're likely to immediately run into a wandering character, triggering a mime animation and restoring the cursor. Either way, if you can avoid people, you can keep walking around park rooms with the wrong cursor.

Attachments (1)

gk1-cd.005 (48.1 KB) - added by sluicebox 2 years ago.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by sluicebox

Attachment: gk1-cd.005 added

comment:1 Changed 2 years ago by m-kiewitz

This definitely does not happen w/ the original interpreter?
Theoretically it could be speed related (computer being too fast).

comment:2 Changed 2 years ago by sluicebox

I can't say that it never happens in the original interpreter. I don't remember it ever happening there, but it happens frequently enough in ScummVM that I keep jotting it down.

comment:3 Changed 2 years ago by csnover

Owner: set to csnover

I can’t ever reproduce this in DOSBox but can consistently reproduce it in ScummVM so I’m pretty sure we’re doing something wrong.

comment:4 Changed 2 years ago by csnover

Owner: changed from csnover to sluicebox

Hm. After some more testing I actually cannot reproduce this problem with a fresh game. When exiting the bookstore and then going immediately to Jackson Square at the start of the game, everything is fine, even after the mime starts following Gabriel.

I had to hack things a little bit for the posted save game to even work, since it seems to have been saved from a different version of the game than mine. So I am uncertain about the nature of this bug.

Can you provide more information about how you got to this point in the game with this save game, and what version of GK1 you are running?

comment:5 Changed 2 years ago by csnover

Resolution: worksforme
Status: newpending

comment:6 Changed 2 years ago by csnover

Owner: changed from sluicebox to csnover
Status: pendingclosed

I haven’t heard anything back about this in a month so I am closing this ticket for now. If this is still a problem please comment and it can be reopened.

Note: See TracTickets for help on using tickets.