Opened 3 years ago

Closed 3 years ago

#9637 closed defect (fixed)

SCI: GK1: Speech settings reset when loading game

Reported by: sluicebox Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game: Gabriel Knight 1

Description

When loading a game in GK1 under ScummVM, the three settings for speech are always reset to their defaults. (Narrator: Voice, Text: Off, Voice: On)

To reproduce:

  1. Set Text to On, Narrator to Text, Voice to Off. (UI requires that order)
  2. Save game
  3. Load saved game
  4. All three settings have been reset

Using latest from default branch, Win7.

  • I don't know what the correct behavior is here, as I know that in other Sierra games on ScummVM these kinds of text/voice settings are tied in to its own settings, and I don't know how all that works. I just know that the settings shouldn't be reset in this scenario.

Change History (2)

comment:1 by csnover, 3 years ago

Fixed in 42ebd5a66449121f8aa68f0e35f3f03b137ece63. Note that in ScummVM, the speech & subtitles audio settings are per game, not per save game, so saving a game, changing the audio settings, then restoring the old save game will not cause the audio settings to change back (except for the Narrator one, since it is not an option that exists in ScummVM).

comment:2 by csnover, 3 years ago

Owner: set to csnover
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.