Opened 3 years ago

Closed 3 years ago

Last modified 12 months ago

#9620 closed defect (fixed)

SPARKLE: Update Error! An error occurred while extracting the archive.

Reported by: angstsmurf Owned by: sev-
Priority: normal Component: Port: Mac OS X
Keywords: Cc:
Game:

Description

When pressing the Check now button in Options on ScummVM 1.9.0, a new version is found and downloaded, but then there is and Update Error! alert. See the attached screenshots.

OS X El Capitan, 10.11.6

I wonder if this has anything to do with Gatekeeper and the signing problems discussed here?https://github.com/sparkle-project/Sparkle/issues/667

Switching off Gatekeeper does not seem to help.

Attachments (3)

Skärmavbild 2016-10-19 kl. 13.12.30.png (218.7 KB ) - added by angstsmurf 3 years ago.
Updates found!
Skärmavbild 2016-10-19 kl. 13.12.41.png (93.4 KB ) - added by angstsmurf 3 years ago.
Downloading…
Skärmavbild 2016-10-19 kl. 13.11.25.png (98.3 KB ) - added by angstsmurf 3 years ago.
Error!

Download all attachments as: .zip

Change History (10)

by angstsmurf, 3 years ago

Updates found!

by angstsmurf, 3 years ago

Downloading…

by angstsmurf, 3 years ago

Error!

comment:1 by angstsmurf, 3 years ago

Update: Apparently it tries to download and extract the Windows binary:

Sparkle: Error: No valid unarchiver for /var/root/Library/Caches/org.scummvm.scummvm/Sparkle/ScummVM 1.9.0.2/scummvm-1.9.0.2-win32.exe!

comment:2 by sev-, 3 years ago

Interesting. Thanks for reporting. So MacOS is trying to pick up a Windows build.

Will look into the setting ASAP.

So far just ignore the update as it is Windows-only.

comment:3 by criezy, 3 years ago

Just a confirmation that it was working yesterday before the addition of the 1.9.0.2 Windows version (I did an update without issues on OS X to take snapshots to update the User manaul on the wiki).

comment:4 by criezy, 3 years ago

The issue also occurs with ScummVM 1.8.1 and for me this is the main issue. Instead of proposing to update to the OS X 1.9.0 version it proposes to update to the Windows 1.9.0.2 version. So mac users who have not yet updated (and since by default the check is weekly I would guess there are a sizeable number of those) cannot update automatically to the newest OS X version.

Maybe we should add a 1.9.0.2 version for OS X as well if we can't find a better solution?

comment:5 by sev-, 3 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

As it appears, there is a lack of functionality in Mac Sparkle.

So far we mitigated it with releasing Mac 1.9.0.2 without any functional changes.

comment:6 by wjp, 3 years ago

What would be the a long-term solution for this? Maybe separate the OS X and Win32 appcasts entirely?

comment:7 by digitall, 12 months ago

Component: --Unset--Port: Mac OS X
Note: See TracTickets for help on using tickets.