Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#962 closed defect (invalid)

MM: Can't feed Chuck the Plant

Reported by: SF/inguin Owned by: SF/ender
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

In Maniac Mansion (extended version, the one that came with the
german DOTT) I cannot feed the carnivorous plant after watering it. If
I try to "give turkey to plant", Dave tells me he needs to be closer to
do so. And "use turkey" doesn't work at all because ScummVM isn't
asking for an object in that case.
Savegame attached.

Ticket imported from: #767246. Ticket imported from: bugs/962.

Attachments (1)

maniac.s01 (58.2 KB ) - added by SF/inguin 16 years ago.
Maniac Mansion savegame

Download all attachments as: .zip

Change History (13)

by SF/inguin, 16 years ago

Attachment: maniac.s01 added

Maniac Mansion savegame

comment:1 by SF/segra, 16 years ago

Same problem here with english version on the latest CVS. I
found Using objects with the plant works... but you cant give.
Give water or pepsi to it and dave wont do it
but using works fine still

comment:2 by SF/inguin, 16 years ago

Argh, stupid me! Until two minutes ago I was absolutely convinced it was
essential to give the water, the rotten turkey, the roast beef and the can of
Pepsi to the plant to satify it. Since neither the turkey nor the roast seem to
be required this bug is far less critical than I judged it. Reducing priority to a
minimum.

comment:3 by SF/inguin, 16 years ago

Priority: normallow

comment:4 by fingolfin, 16 years ago

Did you actually test what the original does in this case (I never
played the original so I have no idea...)

comment:5 by SF/inguin, 16 years ago

Resolution: invalid

comment:6 by SF/inguin, 16 years ago

Just tried it, with both the old and the enhanced version. In both cases the
plant is not a valid target for "give" actions, so the game ignores the plant
after selecting "give $whatever to...". So, while ScummVM's behavior is not
quite correct it at least doesn't prevent you from doing anything you could
do in the original interpreters.
I have no idea why I was so sure I had to feed the plant when it's actually
impossible. Looks like my memory on that part of the game is badly flawed.
Marking my bug report as invalid.

comment:7 by SF/hibernatus, 16 years ago

You shouldn't be able to select the plant when you've
selected the verb "give". That's the real bug.

comment:8 by fingolfin, 16 years ago

hibernatus, just to clarify this: you mean you tried the original,
and ther you couldn't select the plant with the verb "give" ?

comment:9 by SF/inguin, 16 years ago

I'm not hibernatus, but I did try it in the original interpreter (both the old
and the enhanced version) and yes, it does not allow to select the plant as a
target for "give".

comment:10 by SF/ender, 16 years ago

Status: newclosed

comment:11 by SF/ender, 16 years ago

Owner: set to SF/ender

comment:12 by SF/ender, 16 years ago

I'm going to close this, as why it is a behavioral
difference it causes no ill-effects, thus cannot be called
a bug.

Note: See TracTickets for help on using tickets.