Opened 3 years ago

Closed 3 years ago

#9608 closed defect (fixed)

ZVision games crashing on launch

Reported by: exmensa Owned by: dreammaster
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Grand Inquisitor

Description

ScummVM version: 1.10.0git254-gc118e2f

Bug details: Both games (Zork Nemesis & Zork: Grand Inquisitor) crash on launch with error "Invalid TrueMotion1 compression type 31!"
The same data files launch successfully using 1.9.0pre56-gbe61f28.

Language of game: English
Version of game: CD & DVD
Platform and Compiler: Windows 10 32&64-bit, buildbot

Change History (4)

comment:1 Changed 3 years ago by wjp

I can confirm this. It has been caused by the merge of PR 839 ("VIDEO: AVIDecoder changes for Titanic videos").

comment:2 Changed 3 years ago by wjp

Component: --Unset--Engine: ZVision

comment:3 Changed 3 years ago by dreammaster

Damn. My apologies for that. I think I've got a copy of Zork Nemesis.. presuming I can dig it up, I'll try and look into the problem when I get home later tonight.

comment:4 Changed 3 years ago by dreammaster

Owner: set to dreammaster
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.