Opened 5 years ago

Closed 8 months ago

#9604 closed defect (worksforme)

SCI: PHARKAS: Background not cleared after reloading from bar fight

Reported by: hpvb Owned by: bluegr
Priority: low Component: Engine: SCI
Version: Keywords:
Cc: Game: Freddy Pharkas: Frontier Pharmacist

Description

When restoring the game from the death screen after the bar fight it appears that a background buffer isn't cleared properly and the load/save interface gets copied into the letterbox area of the screen, if the window/screen is not at a game-native aspect ratio.

I have attached the save and a screenshot. To reproduce:

  • Make sure your scummvm window is not in the same aspect ratio as the game
  • Load save
  • Click the hand cursor on the third hand that occasionally appears on the center character (you'll see it when you see it)
  • On the new scene click the gun cursor anywhere but behind you
  • On the death screen select 'restore' and select this same save.

Attachments (2)

Screenshot from 2016-10-08 00-10-57.png (187.3 KB ) - added by hpvb 5 years ago.
Corruption
freddypharkas-cd.037 (37.3 KB ) - added by hpvb 5 years ago.
The save in question

Download all attachments as: .zip

Change History (8)

by hpvb, 5 years ago

Corruption

by hpvb, 5 years ago

Attachment: freddypharkas-cd.037 added

The save in question

comment:1 by hpvb, 5 years ago

Note that I haven't seen this behavior at any other point in the game, and I died and restored a lot :) I wasn't a very good pharkas player.

comment:2 by wjp, 5 years ago

Game: Freddy Pharkas: Frontier Pharmacist

comment:3 by wjp, 5 years ago

Summary: SCI: PHARKASSCI: PHARKAS: Background not cleared after reloading from bar fight

comment:4 by hpvb, 5 years ago

This happens occasionally at the beginning of SQ4 also

comment:5 by sluicebox, 9 months ago

I can't reproduce this. Release 1.9.0 is the earliest that matches this save game version and I can't reproduce it using that either.

Using Win32 builds, I'm setting display mode to OpenGL and widening the window so that the ScummVM restore dialog is drawn beyond the game area on the left and right as described, and the entire window is always cleared when restoring from the death screen to the attached save game.

comment:6 by bluegr, 8 months ago

Owner: set to bluegr
Resolution: worksforme
Status: newclosed

I can't reproduce this either. I'm closing this as worksforme

Note: See TracTickets for help on using tickets.