Opened 9 months ago

Closed 8 months ago

#9583 closed defect (fixed)

SCI32: Views from the previous scene are drawn into the next frame after a transition

Reported by: csnover Owned by: csnover
Priority: normal Component: Engine: SCI
Keywords: sci32 Cc:
Game:

Description

In PQ4: At the start of the game, open the dumpster. The policemen from the previous view are rendered on top of the dumpster view.

In SQ6: Warp from room 270 to room 420 to trigger a cutscene during which views appear on top of the cutscene close-ups.

Probably some issue with the priorities of screen items.

Attachments (1)

Screenshot from 2016-10-17 09-29-23.png (27.6 KB) - added by hpvb 8 months ago.
LSL6hires ending sierra logo

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 months ago by m-kiewitz

Summary: SCI: Views from the previous scene are drawn into the next frame after a transitionSCI32: Views from the previous scene are drawn into the next frame after a transition

comment:2 Changed 8 months ago by csnover

Owner: set to csnover

comment:3 Changed 8 months ago by hpvb

This also appears to happen during the ending cutscene of lsl6hires. The SIERRA logo from the textbox remains visible.

comment:4 Changed 8 months ago by csnover

PQ4 rendering is fixed in a854c7e274e1cd5ed77b219762eea6d4d67c47be. Hopefully this fixes any problem with LSL6hires too (let me know!). Unfortunately that SQ6 cutscene’s problem seems to be in another castle.

Last edited 8 months ago by csnover (previous) (diff)

comment:5 Changed 8 months ago by hpvb

I'm afraid it did not fix the LSL6hires ending either.

Changed 8 months ago by hpvb

LSL6hires ending sierra logo

comment:6 Changed 8 months ago by csnover

Per IRC: The LSL6hires logo issue seems to be not a bug in SCI engine rendering code, but rather is caused by loading a game from the ScummVM main menu. LSL6hires really needs its original save/load code to execute to avoid randomly broken stuff, it seems.

comment:7 Changed 8 months ago by csnover

Resolution: fixed
Status: newclosed

Fixed in c9ad2062db80fc9b6339bebdcd70f58269e38bf6.

Note: See TracTickets for help on using tickets.