Opened 11 months ago

Closed 6 weeks ago

#9570 closed defect (fixed)

Selenitic door puzzle skips playing the last sound

Reported by: dafioram Owned by: bgK
Priority: low Component: Engine: Mohawk
Keywords: Cc:
Game: Myst

Description

In the selenitic age after the user has entered the 5 correct sounds and clicks the button to open the door it goes through the sounds except it pauses before the 5th one then skips ahead to the door being open.

If the correct code is used the door opens so the bug is minor.

Scummvm: 64bit 1.9.0git6790-g254f931
Machine: Windows 7 64bit
Game: Myst 95 PC English (not ME!)
Scummvm setting: defaults

Attachments (2)

myst-008.mym (15.0 KB) - added by dafioram 11 months ago.
Myst save files (mym)
myst-008.mys (255 bytes) - added by dafioram 11 months ago.
Myst save files (mys)

Download all attachments as: .zip

Change History (8)

Changed 11 months ago by dafioram

Attachment: myst-008.mym added

Myst save files (mym)

Changed 11 months ago by dafioram

Attachment: myst-008.mys added

Myst save files (mys)

comment:1 Changed 11 months ago by bgK

I can't reproduce this one. It works for me with your save. Does it happen each time for you?

comment:2 Changed 11 months ago by dafioram

No, I did it several times just now and it worked without the bug, every occasion it would happen, but I couldn't get it reproducible.

However, it can be forced to happen if you left click at least once at the end of the door playing the 4rth sound in the sequence (before the last sound). If you click a bunch of times it should definitely happen.

comment:3 Changed 7 weeks ago by dafioram

Win7-64bit 1.10.0git-3567-g58e6033 64bit

The buffering can be seen by watching the video

http://sendvid.com/2ua0wz03

Skip ahead to 18 and the buffering happens about at the 24 second mark. There is no audio, but you can see it pause and then skip ahead.

I was not able to reproduce this bug on an android device.

This also happens in the ME version. You can use myst saves with myst ME saves, btw.

Video expires 8/2/2017 if no ones views before then.

comment:4 Changed 6 weeks ago by bgK

Owner: set to bgK
Resolution: fixed
Status: newpending

Oh, it's Windows displaying a 'busy' cursor, probably because ScummVM doesn't poll it's message queue for too long. Thanks for the video.

I've improved the message polling in sound lock code (834be40ffa). Can you please confirm it is fixed with the next daily build? I can't easily check since I'm not using Windows.

comment:6 Changed 6 weeks ago by bgK

Status: pendingclosed
Note: See TracTickets for help on using tickets.