Opened 16 years ago

Closed 16 years ago

#956 closed defect (fixed)

MI1: Text masking bug

Reported by: SF/madm00se Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

When giving the poisoned meat to the deadly
piranha poodles, the text in the 'IMPORTANT NOTICE'
that pops up is incorrectly hidden by parts of Guybrush
that should be transparent (see attached screenshot).

ScummVM version:
CVS build on Win32 - MinGW
ScummVM 0.4.2cvs
Built on Jul 6 2003 17:43:35
(From a cvs pull from July 5th)

The bug also exists in release 0.4.1
The bug does not exist in the original MI1.

Ticket imported from: #766783. Ticket imported from: bugs/956.

Attachments (2)

text-masking-bug.png (16.0 KB ) - added by SF/madm00se 16 years ago.
Screenshot showing text masking bug
monkeyvga.s02 (54.9 KB ) - added by SF/madm00se 16 years ago.
Saved game at the deadly piranha poodles

Download all attachments as: .zip

Change History (6)

by SF/madm00se, 16 years ago

Attachment: text-masking-bug.png added

Screenshot showing text masking bug

by SF/madm00se, 16 years ago

Attachment: monkeyvga.s02 added

Saved game at the deadly piranha poodles

comment:1 by eriktorbjorn, 16 years ago

The same thing happens with the CD version as well. Just to
clarify, Guybrush should be drawn over the text background
(and according to DOSbox the two versions really do use
different colours for them), so that part's working.

The problem is that the text is partially removed, and I
don't know yet what's causing that.

comment:2 by eriktorbjorn, 16 years ago

More ramblings...

The text appears to be drawn without masking, but that's
probably intentional because if I force it to mask the text
isn't removed afterwards.

Now I think it's our actor redrawing that's being too
aggressive, because it's forcing redraws even when none
should be needed. Usually this wouldn't be a problem, but
apparently there are cases when a game depends on certain
parts of the screen not being redrawn. (See also bug
#744794, though I don't know if it's directly related to
this one.)

Maybe it's a usage bit problem? There are still a few things
about that code that I don't quite understand...

comment:3 by eriktorbjorn, 16 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:4 by eriktorbjorn, 16 years ago

I can no longer reproduce this with the latest CVS snapshot.
I guess Fingolfin's recent redraw logic changes fixed this
problem as well.

Note: See TracTickets for help on using tickets.