Opened 16 years ago

Closed 15 years ago

#954 closed defect (fixed)

COMI: Text should not always have a shadow

Reported by: eriktorbjorn Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Maybe this should be three separate reports...

In CMI, text is (almost) always drawn with a drop
shadow. This is wrong. For instance, the map which
shows how to find Elaine (go to room 38 with the
debugger to see it) should just be plain black text,
and on the native options screen (F1) the text should
not have a shadow, neither when it's black nor red.

I don't know what turns the shadow on or off though.
From what I can see, the script for the map doesn't do
anything special. It's just a bunch of blocks like

[000A] (97) blastText_baseop()
[000C] (97) blastText_charset(3)
[0013] (97) blastText_color(0)
[001A] (97) blastText_center()
[001C] (97) blastText_XY(280,localvar0)
[0028] (97) blastText_msg("/PU_M033/With all eyes open,
follow the path")

A quick-and-dirty solution would be to not draw a
shadow when the text itself is black, which should at
least make all text readable. But it isn't enough to
make the red text draw correctly.

Another text drawing issue (sort of) is in the banjo
duel when playing in easy mode. There's a mouse-over
text for each of the strings on Guybrush's banjo, just
like the original, but there should definitely not be a
voice-over.

Maybe it's enough to just disable voice-overs for blast
texts? They certainly make no sense there anyway.

I'm attaching a savegame at the barbers, because
there's a slight text drawing issue there as well. When
you slap him (to start the duel) his first reply isn't
completely erased. I haven't checked why, but I've seen
similar things before. It may be my imagination, but I
have a vague feeling that it only happens when the
message is drawn close to the edge of the screen.

Ticket imported from: #766749. Ticket imported from: bugs/954.

Attachments (1)

comi.s35.gz (51.2 KB) - added by eriktorbjorn 16 years ago.
Savegame at the barbers, before the duel

Download all attachments as: .zip

Change History (13)

Changed 16 years ago by eriktorbjorn

Attachment: comi.s35.gz added

Savegame at the barbers, before the duel

comment:1 Changed 16 years ago by fingolfin

Summary: CMI: Text drawing issuesCOMI: Text drawing issues

comment:2 Changed 16 years ago by SF/superqult

Here's a screenshot of the text glitch:

http://markus.samsonrourke.com/comi_textglitch01.jpg

comment:3 Changed 16 years ago by fingolfin

Well as long as we have no clue what determines whether to use
shadow or not, I don't see how we could fix this :-/

comment:4 Changed 16 years ago by fingolfin

Priority: normallow

comment:5 Changed 16 years ago by fingolfin

Maybe it is somehow affected/controlled by the setBannerColors()
opcode we currently ignore?

comment:6 Changed 15 years ago by SF/evil_penguin

Regarding the bug described in the last paragraph:

Bug #901443 seems to be another example of dialog subtitles
drawn at the very edge of the screen that get stuck.

comment:7 Changed 15 years ago by fingolfin

The part in the barber shop (text not being properly erased/drawn etc.)
is fixed in CVS. This was reported in at least two other reports as well.

Please always file one separate report for each issue you are reporting.
That makes it possible for us to properly track issues. If you file three
different issues in a single report, it makes handling it a bit painful for us
:-/.

Regarding the banjo duel issue: does it still occur with latest CVS (grab a
daily build from our website to test) ? If yes, can you please attach a
savegame with which I can reproduce the issue?

comment:8 Changed 15 years ago by eriktorbjorn

I only get the subtitles for the banjo strings now, not the
voice-overs, so that one has been fixed now. (I meant to try
it some time ago when I saw a commit message that looked
like it could be about this, but I never did so I don't know
when it was fixed.)

comment:9 Changed 15 years ago by fingolfin

Summary: COMI: Text drawing issuesCOMI: Text should not always have a shadow

comment:10 Changed 15 years ago by fingolfin

Great to hear!

So the only thing which is left is the issue of when to (not) draw text
shadows.... hmmm... could it be the charset? The example that was
pasted above uses charset 3. Indeed, all the shadowless text in the F1
menu, and in room 38, are using charset 3, while everything else seems
to use charset 1.... hmm!

comment:11 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:12 Changed 15 years ago by fingolfin

Fixed the last part of the bug by not drawing a drop shadow for text
rendered with charset 3.

Note: See TracTickets for help on using tickets.