Opened 18 years ago

Closed 18 years ago

Last modified 18 years ago

#95 closed defect (fixed)

Indy4 - Monte Carlo bug.

Reported by: SF/piusii Owned by: SF/ender
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

In Indy 4, CD version I have the attached graphical glitch: in Monte Carlo, the people who should come from the lower left corner walk in from the upper left corner. Going _to_ the lower left corner looks right.
I'm using the newest CVS version, but under Mac OS X, i.e. on a big endian system.

Ticket imported from: #527931. Ticket imported from: bugs/95.

Attachments (2)

Glitch.jpg (64.0 KB ) - added by SF/piusii 18 years ago.
Screenshot Indy4 Monte Carlo
atlantis.s06 (52.7 KB ) - added by SF/piusii 18 years ago.
Savegame Labyrinth Glitch

Download all attachments as: .zip

Change History (16)

by SF/piusii, 18 years ago

Attachment: Glitch.jpg added

Screenshot Indy4 Monte Carlo

by SF/piusii, 18 years ago

Attachment: atlantis.s06 added

Savegame Labyrinth Glitch

comment:1 by SF/piusii, 18 years ago

Found some others: in room 30 (U-Boot), "thinking" way, after you have set the oily cloth on fire via the torpedo control, Indy keeps on walking "out of the screen" without moving forever.

Before Indy fires himself thru the torpedo tube, he dresses as Indy again; this does not take long enough, the door closes, but opens again immediately afterwards.

The last one is really nasty: in the labyrinth, there is this room where you have to use a stick to free a counter weight and then get a gold case. It's room 60. You enter the room from the left side; if you click on the right side just after entering, Indy walks there, although he should not be able to. Problem is, if you click on the shaft in the middle of the room, Indy walks there too, then remembers he may not, and is stuck there. Funniest, he still "feels" like on the left side of the room and can't take the gold case.

Attached a savegame of the last bug: exit the room, then re-enter and immediately click on the right side. It takes timing to do it.

Hope this helps. Let's squish those bugs :-)

comment:2 by SF/ender, 18 years ago

Summary: Indy4 glitch in Monte CarloENDIAN/MAC: Indy4 bugs

comment:3 by SF/ender, 18 years ago

Sounds like an Endian issue then - I'll ask one of our Mac
peeps to take a look :)

comment:4 by SF/piusii, 18 years ago

The newest cvs fix for indy broke things completely: in Monte Carlo, People now walk behind the cars, but in front of the screen; the walking to the upper left corner continues.
In the U-Boot scene, Indy still plays the walking animation till you tell him to go elsewhere, but before the fix, he at least took the right way; now he walks right through the ceiling of the lower deck.

comment:5 by SF/mutle, 18 years ago

Are you using the Native Mac OS X Port, ot the SDL
one? I will have a look at it.

--Mutle

comment:6 by SF/piusii, 18 years ago

I use the SDL port (the native one only seems to have a code
warrior project)

I just see that there are already new fixes in CVS... I
think I'll wait till this box fixes are really finished
since they seem to undergo some changes right now.

The latest Linux i386 version I just compiled from CVS
doesn't have the box problems; however, that could be
because they were just fixed in the last hour, or because
they are endianness bugs.

comment:7 by SF/ender, 18 years ago

Summary: ENDIAN/MAC: Indy4 bugsIndy4 - Monte Carlo bug.

comment:8 by SF/ender, 18 years ago

Ok, turns out this isn't mac or endian specific. Looking
into it.

comment:9 by SF/ender, 18 years ago

Owner: set to SF/ender
Priority: normalhigh

comment:10 by SF/ender, 18 years ago

Updating this - problem still exists in latest CVS. Havn't
found the cause yet... CVS regression somewhere, I guess.

comment:11 by SF/ender, 18 years ago

Component: Engine: SCUMM
Game: Indiana Jones 4

comment:12 by SF/ender, 18 years ago

Changing group/catagory to match new bug guidelines.

comment:13 by SF/ender, 18 years ago

This appears to be fixed in latest CVS. Reopen if you
discover otherwise.

comment:14 by SF/ender, 18 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.