Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#949 closed defect (fixed)

FT: different loudnesses in voices

Reported by: SF/logicdeluxe Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM 0.5.0pre-cvs windows
Built on Jul 5 2003 21:59:31
In some scenes, spoken text sounds much louder than in
others. I am even not able to correct this, when all
volume sliders are at the same position. I think this
was since FT was supported at all. Just listen through
the whole intro.
I checked it with several Windows PC's.

Ticket imported from: #766499. Ticket imported from: bugs/949.

Change History (11)

comment:1 Changed 16 years ago by SF/yarrt

This bug is still present in latest CVS
ScummVM 0.5.0pre-cvs (Jul 22 2003 11:48:08)
ScummVM 0.5.0pre-cvs (Jul 26 2003 03:28:10)

OS: Windows 2000 (SP4)
Dual CPU System.
Language: English
Soundcard: Sound Blaster Live! (value)
Drivers: Creative 5.12.2.252 (24.07.2002)

Sounds like the gain of the sound card is changed
while for certain scenes (also the background noise .

This is an excerpt from the debug lvl 3 (-d3) output,
while the voice/sound gain changed.

>DEBUG: build-shadow-palettes
>loadResource(Script,2)
>playSound #533 (room 98)
>volumeFade is 0, step is -4
>loadResource(Charset,2)
>playSound #533 (room 98)
>playSound #533 (room 98)
>using wrap workaround for 488 bytes
>using wrap workaround for 488 bytes
>using wrap workaround for 488 bytes
<playSound #533 (room 98)
<playSound #533 (room 98)
>using wrap workaround for 2888 bytes
>using wrap workaround for 2888 bytes
>playSound #533 (room 98)
>playSound #533 (room 98)
>using wrap workaround for 1192 bytes
>using wrap workaround for 1192 bytes
>playSound #533 (room 98)
>playSound #533 (room 98)
>using wrap workaround for 3536 bytes
>using wrap workaround for 3536 bytes
>playSound #533 (room 98)
>using wrap workaround for 1840 bytes
>using wrap workaround for 1840 bytes
>playSound #533 (room 98)
>playSound #533 (room 98)
>INSANE Arg: 0

There are two other things I noticed:
>Mixer full... Trying to not break too much (B)

Should this happen ? I got a lot of those message
even though "scummvm" was the only "active" sound playing
application (background icq etc.).
The first time it happend while the old man in the
car was talking to "Rip-burger".

>using wrap workaround for 7616 bytes
(also occoured often with different byte values)

comment:2 Changed 16 years ago by SF/yarrt

The volume level seems to be room depended. In a cut-scene
with many room changes (primarily for closeups of the talking
characters) the volume level jumps everytime the
room/perspective is changed.

comment:3 Changed 16 years ago by aquadran

Owner: set to aquadran

comment:4 Changed 16 years ago by fingolfin

What is the status of this item?

comment:5 Changed 16 years ago by SF/yarrt

Version: ScummVM 0.5.3cvs (Sep 10 2003 13:52:52)
OS: Windows 2000 (SP4)
Dual CPU System.
Language: English
Soundcard: Sound Blaster Live! (value)
Drivers: Creative 5.12.2.252 (24.07.2002)

The problem still exists on ScummVM (Non-OpenGL).
In my opinion sound improved a bit, but there are a few new
short blips (which might be caused by a slow pc).

The ScummVM-OpenGL version has no blips, but overall the
volume is too low (imho) and most scenes suffer (from
unbalanced volume) like the Non-OpenGL version. The game is
much quiter than a MP3 played by winamp.

comment:6 Changed 16 years ago by fingolfin

"blips"? You mean distortion/gaps/stutter/jitter in the sound?
Interesting, what kind of machine do you run on?

"Volume is too low" - did you ever play with the volume controls
in ScummVM, e.g. setting them up?

Finally, my question also was directed at aquadran: Pawel, any
ideas on this one?

comment:7 Changed 16 years ago by SF/yarrt

hi

Sound level is ok (for me) in the following scene:
- Press ESC (to skip the first part of the intro)
Shortly after Corley is inside the pub, Rippburger
and his thugs talk about what might take Corley so long.

When Malcom Corley (the old grey man) enters the bar saying
"Alright who drove over my car ..." the volume is ok ....
and while the Rippburger's thugs talk inside the car...
Example: "Yeah, maybe they took the old guy out back and
worked him with a two-by-four!"
... the volume is ok ... otherwise I have to increase my
system volume to hear anything (even though Master and FX
volumes are set to 255 (via GUI)).

The blips (=short burst distortion) did not occour a second
time, (at least I can not reproduce it now) ... my system was
running more than a day perhaps that was the caused of the
problem (SB Live Driver/Soundcard :( )... or the 100 MBit
Network was busy with copying something else (except
reading the throttle data from disc server).

I also might have used the monster.sog file, as I am not sure
which format ScummVM prefers as both the orig. monster.sou
and the monster.sog exist in the resource directory.

If you need a log or the state of some variable (e.g.
gain/volume level variable) I can provide this information, if I
know what you need.

OffTopic: Is the problem with the ScummVM-CD-Reading bug
fixed ? I remember something about a bug in the windows api
though I am not sure how other ordinary windows/game
software would handle reading from a cd differently ? (without
the bug)

@Fingolfin: My System is a Windows 2000 SP4 machine with a
dual PIII-750, 512 MB RAM, ASUS P2B-DS (Intel BX Chipset)
featuring a Creative SB Live (value) card (though those
drivers are not perfect in my opinion - but better than their
earlier releases).

comment:8 Changed 16 years ago by fingolfin

ScummVM looks for the sound files in this order (assuming the
game target is "ft"):
ft.so3
monster.so3
ft.sog
monster.sog
ft.sou
monster.sou

comment:9 Changed 16 years ago by fingolfin

AFAIK, the "ScummVM-CD-Reading bug" has not yet been fixed by
MicroSoft, no. As to how other games do it: I haven never played
any other games with an Audio CD track on Windows, so I
wouldn't know...

comment:10 Changed 15 years ago by aquadran

difference between smush audio voices and in game voice are
fixed now

comment:11 Changed 15 years ago by aquadran

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.