Opened 16 years ago

Closed 16 years ago

#943 closed defect (fixed)

INDY3EGA - Copy protection screen partially broken

Reported by: SF/quietust Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Indiana Jones 3

Description

The Amiga version of Indy3 runs nicely as 'indy3ega' with
the latest (July 4) CVS build. There are a few minor
issues (no sound, intro ends a few seconds early), but
one major problem that prevents it from being playable:
the copy protection screen does not run properly.

When I click on the notebook, the following message
shows up in the console:
WARNING: getResourceAddress Illegal Glob type String
(7) num 53!

In the game, it does not display the row number
(example: "Check Section 4, Row , Column 4"); this
makes it rather difficult, if not impossible, to actually
play the game.

Ticket imported from: #766237. Ticket imported from: bugs/943.

Change History (9)

comment:1 by SF/hibernatus, 16 years ago

Same thing with the ST version (which should be the same as
the PC version). But anyway, it's a minor bug since the
protection is bypassed.

comment:2 by SF/quietust, 16 years ago

Ah, then there's something else wrong with it - when I go to
Henry's house, the chest (underneath the plant+tablecloth)
and the sticky tape (behind the bookcase) are not registering
as items I can interact with. I seemed to recall something
about that happening if you don't enter the code properly
(though I believe it also disabled travelling to Venice, which is
currently enabled).

comment:3 by SF/hibernatus, 16 years ago

I've tried the ST version with and without bypassing the copy
protection and i can select the sticky tape and the chest in
both cases.
Can you check again with the Amiga version? I would be really
surprised if you weren't able to select the chest. And the
sticky tape is a little hard to aim :)
And yes, the copy protection removed the option to travel to
Venice.

comment:4 by SF/quietust, 16 years ago

Weird... NOW it works.
Incidentally, I was using "What is" to locate the chest and
sticky tape before, and they weren't registering (sticky take
was showing up as bookcase, chest wasn't showing up at all).
Maybe there was something else I was doing that it didn't
like, but whatever it was, I can't get it to happen again
(skipping the intro, skipping the chat with Marcus, skipping
the chat with Donovan, not picking up the package containing
the Grail diary, not opening the package, etc.)

comment:5 by Kirben, 16 years ago

Yes, the copy protection glitch effects the PC version as well.

comment:6 by Kirben, 16 years ago

Summary: INDY3EGA - Amiga copy protection screen partially brokenINDY3EGA - Copy protection screen partially broken

comment:7 by SF/quietust, 16 years ago

ScummVM 0.5.0pre-cvs (Jul 20 2003 00:33:19) - works fine
now. This was probably fixed along with #770344.

comment:8 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:9 by fingolfin, 16 years ago

This has been fixed by my fix for bug #770344

Note: See TracTickets for help on using tickets.