Opened 16 years ago

Closed 16 years ago

Last modified 8 months ago

#940 closed defect (fixed)

0.5.0 RC: Talktext glitches while scrolling

Reported by: SF/logicdeluxe Owned by: SF/khalek
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

ScummVM 0.4.2cvs
Built on Jul 5 2003 00:28:03
This affects all games which display the text at the
top of the screen. When the screen scrolls, only a few
letters appear and stay there until a new line is said.
You can reproduce it easily: For example start MM and
try reading the bushes in front of the mansion and walk
away while your person is still complaining. This also
happens when you run away from Edna in the kitchen,
where you have no chance in reading Edna's line at all,
since it scrolls immediately etc.. It appeard some days
ago, I think.

Ticket imported from: #766109. Ticket imported from: bugs/940.

Change History (10)

comment:1 Changed 16 years ago by eriktorbjorn

That some characters are left behind is probably because of
the recent camera fix with scrolling text. I guess the text
area (gdi._mask) should only move along with the scrolling
if it's inside the area covered by virtscr 0.

But that still doesn't explain why the text is cleared. I
have no idea about that yet.

comment:2 Changed 16 years ago by fingolfin

This is actually a duplicate of bug #764610. Since this one is
more generic, I'll close #764610.

Regarding the camera change, if you just comment out / remove
the code I added, the problem is still there; so it's clearly not the
cause, although I agree it should only shift the charmask if it's in
the main virt screen.

comment:3 Changed 16 years ago by SF/ender

Priority: normalblocker
Summary: Talktext glitches while scrolling0.5.0 RC: Talktext glitches while scrolling

comment:4 Changed 16 years ago by SF/ender

This problem is now release critical. Although it does not
affect gameplay, it is definatly a regression and does
ruin the experience.

An easy test is ZakDemo where some lines are obviously
deleted.

comment:5 Changed 16 years ago by eriktorbjorn

Looks like it's the stopTalk() call in redrawBGAreas()
that's removing the text. But I thought that had been there
since roughly forever, so I don't know why it would cause a
regression now.

comment:6 Changed 16 years ago by SF/logicdeluxe

Then don't call that stopTalk() in this manner with v1-3
games. Just an observation of mine: the later games with the
text within the graphics are designed in such a way, the
actors wait for the end of scrolling before they begin to
talk. I think this was done to avoid such problems, but this
doesn't keep the scene from scrolling while text is spoken.
Also there, the text vanishes in the original interpreters,
but the games are designed in such ways, this never happens
in such critical aspects as we have with MM, ZAK etc. with
certain situations.

comment:7 Changed 16 years ago by SF/khalek

Status: newclosed

comment:8 Changed 16 years ago by SF/khalek

Owner: set to SF/khalek
Resolution: fixed

comment:9 Changed 16 years ago by SF/khalek

reverted change made by rev 1.140 of string.cpp which fixes
this
well the zakdemo anyway. It was said zakdemo was an example
of this so I assume maniac is also fixed.

comment:10 Changed 8 months ago by digitall

Component: --Unset--Engine: SCUMM
Game: Maniac Mansion
Note: See TracTickets for help on using tickets.