Opened 16 years ago

Closed 16 years ago

#934 closed defect (fixed)

BASS crashes when using linc terminal

Reported by: SF/dirtyhairy Owned by: SF/ender
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

The game chrashes when I use Reichs ID-card with the linc-terminal just right from the exit of the valve-factory
gdb output:

Trying. to start game 'Beneath a Steel Sky'

Program received signal SIG32, Real-time event 32.
0x401d7c82 in sigsuspend () from /lib/libc.so.6
(gdb) continue
Continuing.
Entries in dinner table: 1404
WARNING: Stub: fnCloseHand!
WARNING: Stub: fnOpenHand!
WARNING: Stub: fnCloseHand!

Program received signal SIGSEGV, Segmentation fault.
0x080c9929 in SkyLogic::fnIncMegaSet(unsigned, unsigned, unsigned) (this=0x0,
a=0, b=3, c=0) at sky/logic.cpp:1967
1967 _compact->extCompact->megaSet += NEXT_MEGA_SET;
Current language: auto; currently c++
(gdb) bt
#0 0x080c9929 in SkyLogic::fnIncMegaSet(unsigned, unsigned, unsigned) (
this=0x0, a=0, b=3, c=0) at sky/logic.cpp:1967
#1 0x080c8678 in SkyLogic::script(unsigned short, unsigned short) (
this=0x82349a8, scriptNo=18856, offset=65) at sky/logic.cpp:1218
#2 0x080c72dd in SkyLogic::logicScript() (this=0x82349a8) at sky/logic.cpp:137
#3 0x080c723f in SkyLogic::engine() (this=0x82349a8) at sky/logic.cpp:109
#4 0x080b8240 in SkyState::go() (this=0x820d9e0) at sky/sky.cpp:137
#5 0x080d802b in main (argc=3, argv=0xbffff784) at common/main.cpp:230
#6 0x401c715a in __libc_start_main () from /lib/libc.so.6
(gdb)

Ticket imported from: #764775. Ticket imported from: bugs/934.

Change History (4)

comment:1 by SF/dirtyhairy, 16 years ago

P.S.: I forgot, I use Linux, Mandrake 9.0 free. Bug happens with CVS version from 02.07.

comment:2 by Kirben, 16 years ago

Component: --Unset--Engine: Sky
Game: Beneath a Steel Sky

comment:3 by SF/ender, 16 years ago

Owner: set to SF/ender
Resolution: fixed
Status: newclosed

comment:4 by SF/ender, 16 years ago

This is fixed with todays CVS, and was caused by an
unsupported version with unknown Compacts.

Note: See TracTickets for help on using tickets.