Opened 10 years ago

Closed 8 years ago

Last modified 12 months ago

#9170 closed patch (wontfix)

GSoC: COMI: Bug fix for Guybrush walking in Place

Reported by: SF/toneman1138 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Patch against svn trunk as of April 16th.

This patch fixes a bug with Guybrush walking in place when examining certain objects with the 'e' key while walking.
The original game did not have this behavior. The error was probably caused because the objects in question
don't enforce a "walk to" point for Guybrush before he makes his remarks. The patch manually causes Guybrush to
stop walking before processing the scripts triggered by the "examine" command in these specific cases.

Bug 2823309 in the bug tracker.

Tony Puccinelli

Ticket imported from: #2988826. Ticket imported from: patches/1275.

Attachments (2)

bug2823309.patch (1.3 KB ) - added by SF/toneman1138 10 years ago.
Bug fix: Guybrush walking in place when examining certain objects with 'e' key
bugfixlog.txt (3.7 KB ) - added by SF/toneman1138 10 years ago.
log of process of fixing bug

Download all attachments as: .zip

Change History (10)

by SF/toneman1138, 10 years ago

Attachment: bug2823309.patch added

Bug fix: Guybrush walking in place when examining certain objects with 'e' key

comment:1 by salty-horse, 10 years ago

Summary: GSoC: Bug fix for Guybrush walking in PlaceGSoC: COMI: Bug fix for Guybrush walking in Place

comment:2 by SF/toneman1138, 10 years ago

Upon some further testing, I've noticed that the bug occurs for more than just the objects listed in the bug tracker report. In fact, you can get Guybrush to walk in place when examining many objects that are off in the distance/high up (objects where it makes sense for Guybrush to not have to walk to a specific point before remarking). It seems examining many of these objects, including the distant beach, tiki lamps, voodoo lady's domain exterior, etc. triggers the same script (38). I'll look into this more and possibly submit an updated patch once I've caught up with my coursework this week. I've also uploaded a log I kept while working on the bug fix. :-)

by SF/toneman1138, 10 years ago

Attachment: bugfixlog.txt added

log of process of fixing bug

comment:3 by bluddy, 10 years ago

Looks good. And good job adding the log file -- it gives us just the info we want to see :)

comment:4 by fingolfin, 10 years ago

Thanks for the patch. This works around the imminent issue. However, I think there must be a bug in our engine itself, as according to Kirben on the bug tracker, in the original game Guybrush will complete walking to the target before starting to talk. So this hints that we either should execute this script later; that there should be some delay somewhere; or something else is not quite right in our VM...

comment:5 by SF/toneman1138, 10 years ago

I see your point. In light of the bug likely being caused by an engine problem, I'll hold off on implementing the same workaround for other objects (like the voodoo lady's boat) for now. When I get some time between school projects, I'll try to get at the root of the problem.

comment:6 by bluegr, 8 years ago

After speaking with kirben, I'm rejecting this one, as it clearly wasn't the right solution to the problem.

This patch is linked from the bug report, and the attached log and proposed solution are a very good starting point in pinpointing the actual bug.

Thanks for your submission and the detailed explanation! Closing

comment:7 by bluegr, 8 years ago

Owner: set to Kirben
Resolution: wontfix
Status: newclosed

comment:8 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Monkey Island 3
Note: See TracTickets for help on using tickets.